[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Error upgrading xlibs to testing



On Sat, Mar 22, 2003 at 06:23:32PM -0500, nathan_salwen@ncsu.edu wrote:
> after editing the /etc/apt/sources.list I ran
> > apt-get update
> > apt-get dist-upgrade
> 
> and then got the following error
> 
> 
> Preparing to replace xlibs 4.1.0-16 (using .../xlibs_4.2.1-3_i386.deb) ...
> Unpacking replacement xlibs ...
> dpkg: error processing /var/cache/apt/archives/xlibs_4.2.1-3_i386.deb (--unpack):
>  trying to overwrite `/usr/X11R6/lib/X11/app-defaults', which is also in package dialdcost
> Analyzing /usr/X11R6/lib/X11/app-defaults:
> drwxr-xr-x   13 root     root         4096 Mar 22 17:22 /usr
> drwxr-xr-x    6 root     root         4096 Jul 26  2002 /usr/X11R6
> drwxr-xr-x    4 root     root         4096 Mar 22 17:24 /usr/X11R6/lib
> drwxr-xr-x   12 root     root         4096 Mar 22 17:24 /usr/X11R6/lib/X11
> drwxr-xr-x    2 root     root         4096 Mar 22 17:24 /usr/X11R6/lib/X11/app-defaults
> ERROR: /usr/X11R6/lib/X11/app-defaults is not a symbolic link.  The package 
> preinst script should have failed.
> Please report the package name, version, and the text of the above error 
> message(s) to <debian-x@lists.debian.org>.
> dpkg: error while cleaning up:
>  subprocess post-installation script returned error exit status 1
> 
> only after running 
> > dpkg -r dialdcost
> did
> > apt-get install xlibs
> run ok.

Future versions of the XFree86 package will help you better diagnose
this sort of problem.

Thanks for the report!

-- 
G. Branden Robinson                |      The National Security Agency is
Debian GNU/Linux                   |      working on the Fourth Amendment
branden@debian.org                 |      thing.
http://people.debian.org/~branden/ |      -- Phil Lago, Deputy XD, CIA

Attachment: pgp4XivbACOED.pgp
Description: PGP signature


Reply to: