[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#177731: xserver-xfree86: DRI output garbled for i810 driver



On Wed, Jan 22, 2003 at 09:50:26AM -0600, Colin Watson wrote:
> On Tue, Jan 21, 2003 at 05:08:30PM +0100, Lars Steinke wrote:
> > Package: xserver-xfree86
> > Version: 4.2.1-4
> > Severity: important
> > 
> > Since upgrading to 4.2 the i810 3d acceleration produces quite unusable
> > results, for instance glxgears is repeatedly copied across to whole
> > screen width and looks sort of "interlaced" and squashed, i.e. every second 
> > row is not displayed or at least misaligned horizontally. The same applies
> > to full screen OpenGL apps like bzflag...
> 
> I've experienced the same problem on my i810 laptop. Let me know if
> there's anything I can do to help debugging.

So we now know it IS an actual problem and not just me being stupid ;).
Personally I wouldn't know how to go about debugging this one. Running
strace on the X Server and crosschecking with the source, I presume. The
fastest way would be to have someone upstream look at it, they must
know what has been changed in i810 for 4.2 and thus should be able to
put a finger on it comparatively quickly. Branden seems to have
forwarded the bug report to the XFree project so we might see a fix in
4.3 eventually...

Regards,
-- 
       /(__  __|\          Lars Steinke, Stuttgart, Germany
      (    \/  __)_        Physicist & Tech. Supp. Engineer
       )   (_____  /       For information see www.lsweb.de
      /___________/        Debian GNU/Linux: www.debian.org

Attachment: pgpjV2HW2099H.pgp
Description: PGP signature


Reply to: