[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#171305: Xfree86 Package Configuration Failure

Package: xserver-xfree86

Version: 4.2.1-3

Installation fails, with an apparently endless series of lines complaining
about input overruns, when I try to upgrade from version 4.1.0. Following
is an example, recorded after I downloaded the .deb packages, from a 
console without X running.

Reading Package Lists...
Building Dependency Tree...
The following extra packages will be installed:
  libc6 libc6-dev libc6-pic libdb1-compat locales 
The following NEW packages will be installed:
5 packages upgraded, 1 newly installed, 0 to remove and 394  not upgraded.
Need to get 0B/14.0MB of archives. After unpacking 1012kB will be freed.
Do you want to continue? [Y/n] 

Preconfiguring packages ...

ttyS: 1 input overrun(s)
ttyS: 257 input overrun(s)
ttyS: 257 input overrun(s)
ttyS: 257 input overrun(s)
ttyS: 257 input overrun(s)
ttyS: 257 input overrun(s)

etc., continuing until I press ctrl-c. I tried this several times; sometimes
the numbers differ, on two occasions the keyboard froze.

To test whether one of the the extra packages is responsible, I installed
them separately, using dpkg. Then I ran dpkg on the xserver-xfree86
package, and the above overrun(s) lines again appeared.

Kernel version is 2.4.20-pre7-ac3, libc-2.2.5.so is on the system.

Motherboard is an intel 845 with P4 1700 MHZ cpu. /home directory is set up 
with software raid 1. The kernel is the result of two patches applied to 
version 2.4.19, in order to support a Promise ultra 133 TX2 controller. Two 
hard drives: seagate 80 GB 7200 rpm and quantum 15 GB 5400 rpm.

Bob Parnes

Bob Parnes

Reply to: