[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#135075: xterm: no dead keys in uxterm

On Tue, Feb 19, 2002 at 08:18:56PM +0200, Thomas PARIS wrote:
> It seams uxterm starts an xterm that does not support dead keys.
> According to my tests, the problem lies in the fact that uxterm changes
> the locale before starting the xterm.
> In fact, I first tried to change my locale to fr_FR.UTF-8 (supported by
> my system) and then to start an xterm with the -u8 option and I couldn't
> use the dead keys.

I have the same (or at least a similar) problem with current X packages
(version 4.2.1-3).  I am using an UTF-8 locale now by exporting
LANG=de_DE.UTF-8 from .xsession, xterm runs with with utf8 resource set.

I'm using the compose key instead of dead keys and I can't enter any of
the accented characters (like äáàâ etc.).  Other chars like ø and ß can
be entered without a problem.

Problem can be worked around by starting xterm with a locale that's not
UTF-8 (e.g. de_DE) then setting LANG in the running xterm.  Setting LANG
to empty seems to make every non-ASCII character unavailable however,
the compose is interpreted like an escape sequence or something
(<compose> + " + o acts like esc + 6).

The thing is, the same happens to other apps (I just tested galeon,
gnumeric, xedit - the accent composes don't even seem to arrive at the
app, like in xterm) and can be worked around the same way.  The only
exception is that other programs do not act differently with empty LANG
and LANG=de_DE.

There is something going wrong below xterm, either xlibs or libc locales
are messing something up with the combination of UTF-8 and accents.

Andreas Bombe <bombe@informatik.tu-muenchen.de>    DSA key 0x04880A44

Reply to: