[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

DRI fails to work with no errors?

Hi, according to /proc/pci, I have a "ATI Technologies Inc 3D Rage Pro
AGP 1X/2X".

I compiled agp and the r128 DRI driver for kernel 2.4.3-ac5.
This seems to work: I get these messages:

agpgart: AGP aperture is 64M @ 0xf8000000

[drm] AGP 0.99 on Intel 440BX @ 0xf8000000 64MB
[drm] Initialized r128 2.1.2 20001215 on minor 63

However, glxinfo says I'm not running with direct rendering enabled, and
sure enough, there is nothing in my /var/log/XFree86.0.log file to
indicate that drm loaded successfull (or not) except this:

(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules-dri/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
        compiled for, module version = 1.0.0
        ABI class: XFree86 Server Extension, version 0.1

When XAA is initialized, I just get this:

(==) ATI(0): Write-combining range (0xf5000000,0x800000)
(II) ATI(0): Using XFree86 Acceleration Architecture (XAA)
        Screen to screen bit blits
        Solid filled rectangles
        8x8 mono pattern filled rectangles
        Indirect CPU to Screen color expansion
        Solid Lines
        Offscreen Pixmaps
        Setting up tile and stipple cache:
                20 128x128 slots
                5 256x256 slots
(==) ATI(0): Backing store disabled

No complaints, no nothing.
I first was using Branden's debs, but then I installed
xserver-xfree86-dri and added the two lines to my /etc/X11/XF86Config-4
file, and I get the same results.

I suppose I should fetch and compile the dri modules from the sources at
dri.sourceforge.net?  However, is there anyway to find out why drm is
NOT loading already?

Thanks a lot,
Einstein did not prove that everything is relative.
Einstein explained how the speed of light could be constant.
Benjamin Redelings I      <><     http://www.bol.ucla.edu/~bredelin/

Reply to: