[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [rdice@pobox.com: Re: Xfree 4.0.2 driver module problem for ATI R128 (unstable) (Debian Bug report logs - #81007)]

Branden Robinson wrote:

> I've lost control of my mouse.  The touchpad and the eraser-head mouse-like
> devices on my laptop (Dell Inspiron 4000) are completely non-responsive
> under X, and the PS/2 mouse that I've got plugged into the back of the
> computer goes completely nonlinear and nonfunctional with the switch to the
> "ati" driver.  I was wondering if this sounds at all familiar to either of
> you, and if a solution is known.
> The relevant portion of my XF86Config-4 file is...
> .........
> Section "InputDevice"
>     Identifier   "Generic Mouse"
>     Driver       "mouse"
>     Option       "CorePointer"
>     Option       "Protocol"         "PS/2"
>     Option       "Device"           "/dev/psaux"
>     Option       "Emulate3Buttons"  "true"
> EndSection
> .........
> ... and ls -l /dev/psaux gives me
> .........
> crw-------    1 root     root      10,  1 Dec 22 00:54  /dev/psaux
> .........
> This all seems pretty normal to me.
> However, I can't claim that this all is a controlled experiment.
> In the time that my XFree86 4.0.1 was down with the attempted 4.0.2
> upgrade, I recompiled my kernel to Linux 2.2.18 and also tried installing
> the Xig X package as well.  The kernel recompile was with options that
> had always worked for me on my 2.2.17 kernel, but it's always possible
> that Xig left crud hanging around when I de-installed it that could
> interfer with Xfree86 4.0.X.

Can't you try with 2.2.17 again?

Did you by chance enable the New Input Layer in the 2.2.18 kernel?

> Anyhow... obviously, with the kind of radical stuff I've done, there
> is plenty of room for random, hard-to-figure-out errors.  But if
> either of you are aware of a known mouse issue with the ati driver
> attempt, please let me know. (btw, I tried the "vga" driver as well --
> the same thing happened with the mouse)

Display drivers and the mouse are orthogonal so this was to be expected.

> Btw... do either of you have any experience with trying to get XFree86
> to provide output to a notebook's LCD screen and an external video
> device (monitor, data projector, etc.) _simultaneously_?  I've been
> fighting with this for weeks.  I'm starting to think that the r128 driver
> that I had been using simply can't provide this capability.

That's right.


Earthling Michel Dänzer (MrCooper)  \  CS student and free software enthusiast
Debian GNU/Linux (powerpc,i386) user \   member of XFree86 and The DRI Project

Reply to: