[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

DRI problem with Voodoo3 and quake 3


I've searched high and low to see if someone else has had this problem,
but no luck, so I'm posting this here.

This is my setup:

linux 2.4.0-test9
X 4.0.1 packages, phase2v19
Glide v3.10 for DRI
Voodoo 3 3000 AGP

I've recently started having a problem running Quake 3, the following is
what happens when I start it:

----- R_Init -----
...loading libGL.so: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.0
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Xlib: sequence lost (0x10000 > 0x1d) in reply type 0x0!
X Error of failed request:  BadAtom (invalid Atom parameter)
  Major opcode of failed request:  0 ()
  Atom id in failed request:  0x400
  Serial number of failed request:  0
  Current serial number in output stream:  29

...and it quits.  It used to work fine with a previous version of the
X4.0.1 packages, but unfortunately I don't remember which version it was
that started not working.  At one point I was using the tdfx_dri.o
module from the X 4.0.1 I had compiled myself before the phase2 packages
began including it, and that worked fine.  But now it does this same
thing with either one I try.  If I go back entirely to my compiled X,
though, quake 3 works (though at half-speed, but that's something else
entirely I think).  

Something odd,  I just tried some other GL apps, (some GL xscreensavers,
terminus, chromium-bsu) and they seem to be working fine...  I've no
idea why only quake 3 would refuse to work...

I'd really appreciate it if anyone had any ideas or suggestions...

Joel Fuster

Reply to: