[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

OpenGL & G400


First of all, I'd like to thank Branden for his hard work,
and report that upgrade from 3.3.6 to 4.0.1-phase2v13 went
really smooth on my Woody installation. Upgrades v13-v15
and v15-v17 also worked great, which means that either
I'm lucky or the phase2 packages are in better shape
that it is widely advertised :) Anyway, I'm another happy
owner of very useable 4.0.1 system.

The only problem I'm having is the OpenGL support.
I have a Matrox G400 card, and I have followed the instructions
provided earlier on the list. 

+ I have 2.4.0-test8 kernel
+ modules agpgart & mga are loaded
+ I have mga_drv.o from Matrox (rev Beta 1.00.003)
+ I have libGLU.so.1.2.0 from libutahglx1_0.0-20000921-5.deb
+ I run the server on single head, depth 16

I'm getting the following messages on server startup:
(0): [drm] created "mga" driver at busid "PCI:1:0:0"
(0): [drm] added 4096 byte SAREA at 0xc377d000
(0): [drm] mapped SAREA 0xc377d000 to 0x4001b000
(0): [drm] framebuffer handle = 0xd8000000
(0): [drm] added 1 reserved context for kernel
(II) MGA(0): [drm] Registers = 0xd4000000
[drm] drmAgpEnabled succeeded
(II) MGA(0): WARP Microcode Loaded
(II) MGA(0): [drm] calced backoffset: 0x307000
(II) MGA(0): [drm] added 31 65536 byte DMA buffers
(II) MGA(0): [drm] Mga Dma Initialization start
(II) MGA(0): [drm] Mga Dma Initialization done
(II) MGA(0): [drm] Initialized Dma Engine
(II) MGA(0): [drm] dma control initialized, using IRQ 11
(0): X context handle = 0x00000001
(0): [drm] installed DRM signal handler
(0): [DRI] installation complete
(II) MGA(0): direct rendering enabled
(II) MGA(0): Using overlay video

Alas, glxinfo program outputs the following:
display: :0.0  screen:0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, 
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Precision Insight, Inc.
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 Mesa 3.4

And the hardware acceleration is indeed not working,
for exaple Q3A draws a single frame in 3-5 seconds.

I'd appreciate any hints for what I could be missing here.

Thanks in advance for your time!


Here are another problems I encountered, that I'm sure are not
related to the packaging, still I'd like to share information
with other Matrox users:

- When using dual head with depth of 32bpp, I experience artifacts on
  the primary monitor (black vertical lines, colorful shadows).
- Virtual consoles do not work, if matroxfb driver is used. Works fine
  with vga 80x25 console (but who would like to use it? :))
- When using kernel 2.4.0-test9, X server fails to start if agpgart
  module is loaded. The message is as following:
(II) MGA(0): [drm] Sarea 2176+624: 2800
(0): [drm] loaded kernel module "mga"
(0): [drm] created "mga" driver at busid "PCI:1:0:0"
(0): [drm] added 4096 byte SAREA at 0xc5012000
(0): [drm] mapped SAREA 0xc5012000 to 0x4001b000
(0): [drm] framebuffer handle = 0xd8000000
(0): [drm] added 1 reserved context for kernel
(EE) MGA(0): [drm] MGADRIScreenInit failed (DRM version = 2.0.1,
expected 1.0.x).  Disabling DRI.
(0): [drm] failed to remove DRM signal handler

Fatal server error:
Caught signal 11.  Server aborting

Rafal Krzewski
Senior Internet Developer
+48 22 8534830 http://e-point.pl

Reply to: