[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

XFree86 4.0.x test notes

I have being using 4.0.x on debian woody with the following hardware +
software setup since Phase2 debs started to show up.

Voodoo 3 2000 (pci) video card
Logitech cordless wheel mouse (ps/2)
Abit KA7 motherboard (RX and TY bios)
Samsung SyncMaster 955SL monitor

2.4.0-test[1,5,6,8,9] kernel
I have the following notes

Mouse problems
The mouse jumps allover the place and clicks randomly if I'm running X as a
regular user and gpm is running

The mouse will not move if I run X as root and gpm is running.

The mouse occasionally clicked (while moving) until I upgraded my
bios to the TY bios.  BTW.  The TY bios fixes a "win95 only" ps/2 mouse bug.

My XF86Config-4 says the following

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "MouseManPlusPS/2"
        Option      "Device" "/dev/psaux"

Dexter wouldn't run as /etc/X11/dexter-tmp didn't exist.  This stoped
phase2v14 xserver-xfree86 debs from installing.

Dexter wouldn't detect my mouse (I with gpm on and gpm off, I tried linking
/dev/mouse to both /dev/gpmdata and /dev/psaux ie. ln -sf /dev/psaux

Dexter doesn't list any refresh rates between 60 and 85 for the resolution
1280x1024 (I use 79 (75 will do but 60 is yukky and 85 doesn't work)).

Is anyone else having similar mouse problems?  Does anyone have a similar
mouse working corectly


Reply to: