[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: could not open default font


I had to do this to solve the problem:-

apt-get remove xfonts-base
dpkg --purge xfonts-base
apt-get install xfonts-base

The purging of the directory solved the problem for me as a new set of font information was installed alongside the fonts but it took a good 2 hours to work out what the problem was.

Hope that helps,

Ben Thompson

sam th <sam@uchicago.edu> wrote ..
> Hash: SHA1
> When running the command `XFree86 -xf86config /root/XF86Config.new` as
> suggested by -configure, I get the following error at the end.  Attached
> is the whole log, gzipped.
> There are no font paths in that config file, but according to the man
> page, it reads the defaults anyway, and they are correct.
> I have installed the 2v13 .debs for xfonts-base, -scalable, -75dpi and
> - -100dpi.  I have tried this with and without xfs running.   
> I can't think of anything else to try.  
> (**) Option "Device" "/dev/mouse"
> (==) Mouse0: Buttons: 3
> (II) Keyboard "Keyboard0" handled by legacy driver
> (II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
> Couldn't load XKB keymap, falling back to pre-XKB keymap
> (EE) Mouse0: cannot determine the mouse protocol
> Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from
> list!
> Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from list!
> Fatal server error:
> could not open default font 'fixed'
> 	sam th		     
> 	sam@uchicago.edu
> 	http://www.abisource.com/~sam/
> 	GnuPG Key:  
> 	http://pgp5.ai.mit.edu:11371/pks/lookup?op=get&search=0xCABD33FC
> Version: GnuPG v1.0.1 (GNU/Linux)
> Comment: For info see http://www.gnupg.org
> iD8DBQE53bG/t+kM0Mq9M/wRAmf4AKDIeGTwzbhh35VFyPP+dq//p8tD6gCgp89O
> /weTvteUJgwPYh4NSCBdFTE=
> =3t9M

Reply to: