[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian Running Radius



Not sure if you can help with this one, I have searched Google and also your archives but cannot find an answer to my problem.


I have created a Radius startup script in /etc/init.d for Debian which looks like this:



/usr/local/sbin/radiusd -X /usr/local/var/log/radius/radacct/ -d /usr/local/etc/raddb/


Now this works but when I boot my server it shows as ‘ready to process requests’ and it doesn’t login. I can’t get a login prompt. If I do a CTRL –C to try close this it doesn’t work and just shows CTRL C on the screen, I can type in kill radius but nothing happens.


I guess it’s because my script is in debugging mode, most of the suggestions for a script said I should use:



/usr/local/sbin/radiusd -a /usr/local/var/log/radius/radacct/ -d /usr/local/etc/raddb/


However the radiusd –a doesn’t work and if I try to run using command radiusd –a in it comes up and says ‘invalid command’ and I don’t have the option to use the –a


So if this script runs on my server, I could connect to the server through a putty session via port 22 and log on fine and do what I need too, but if I try to connect to the server directly after boot its just sitting on ‘ready to process requests’ and I cannot do anything when directly at the server. On one particular server I didn’t have the network confg right so I couldn’t putty to it and now I’m a bit stuck. Will I need to rebuild my server? As I can’t break out of this ‘ready to process requests’ and I cannot login as its just sitting there, I have tried connecting through serial management via my laptop but I cant do anything this way either the only way I could do anything was if I could get through to the server on putty.


There must be a way when directly at the server to cancel the radius and get logged in? As I’ve mentioned CTRL C doesn’t work. I can get to the ok prompt but not sure what command to use and if I could change the network config at the ok prompt or if I could somehow cancel the startup script at the ok prompt? I thought I could use the init commands to start the server without the script starting but the init commands don’t work and the server just sits there.


Please help out if you can?


Also I guess I shouldn’t be using radius –X in my startup script, to prevent this problem is there something else I should be using? I tried using radius –x (the small x) and I hit enter and then no process for radius starts so I’m a bit confused.


Thank you




This email and any attached files transmitted are confidential and intended solely 
for the person or entity to whom it is addressed. If you received this email in error 
you may not take action based on its contents, nor should you copy, print or show 
this to anyone; instead please reply to the sender and highlight the error, then 
delete the message from your system. 

Please note that the content of e-mail sent and received may have to be disclosed
by the Council in response to a request for access to information. 

Sunderland is aiming to become the most liveable city in the UK.
Visit www.Sunderland.gov.uk  for Council services and information.
Business investors can access www.Investinsunderland.co.uk 
Visitors to the City should log onto www.Visitsunderland.com

Reply to: