[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Confusing search result on packages.debian.org

I accessed the package search on packages.debian.org through
backports.org. I wanted to see if there is a backport for iceweasel 3.5.
So I searched for package name "iceweasel", which yielded this search URL:


No search results are shown, but there is a message:

"Your keyword was too generic.
Please consider using a longer keyword or more keywords."

The exact package name is too generic? As I am searching for package
names it doesn't make sense to add more keywords. I tried it anyway and
it resulted in:

"Sorry, your search gave no results"

So I tried to make the search less generic by selecting "only show exact
matches", and by selecting a specific platform, but it still complained
the keyword was too generic. Then I made the search *more* generic by
clicking "all suites". That gave me results, and the message changed to

"Your keyword was too generic, for optimizing reasons some results might
have been suppressed.
Please consider using a longer keyword or more keywords."

>From the exact hits section it became clear there is no backport for

The first search should have resulted in "Sorry, your search gave no
results", as there were no results to give. The actual message makes you
believe you can get results by being more specific, which isn't true.

This is *very* confusing.

It seems to me the message may be based on intermediate search results,
not the end result. Perhaps the matching package list is truncated
before looking for the packages in the requested suite. If so, the
search optimization algorithm could do with some optimization itself, in
my view.

Reply to: