[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Supporters brief-up

On Saturday 24 July 2004 4:54 pm, Steve Langasek wrote:
> On Sat, Jul 24, 2004 at 03:06:57PM -0700, Carla Schroder wrote:
> > On Saturday 24 July 2004 2:50 pm, Steve Langasek wrote:
> > > On Sat, Jul 24, 2004 at 12:21:20PM -0700, Carla Schroder wrote:

> You have a mixed Libranet/Debian system; you have apt pinning in place
> (either provided by Libranet, or added by you) which gives libranet's
> archive preference over Debian's; and you have overridden these pinning
> preferences to install the perl from sid.
> Yes, it's not sid that's broken. ;)
> I'll take a shot in the dark here -- I think you'll find, if you take a
> look at apt-cache show libnet-perl, that libranet's 1:1.12-1 version of
> libnet-perl has a Conflicts: either with newer versions of perl, or with
> some package that perl depends on.
> You can resolve this by running 'apt-get install libnet-perl/testing'.
> (Or 'apt-get install libnet-perl/unstable, since they're the same
> version.)
> If that doesn't work, it's probably a deep, dark problem with the
> version of apt you have installed -- which I assume is also the Libranet
> version, since no one else is seeing this problem.

 Thanks for a quick response. Specifying a specific version is always the 
first thing I try, and that did not work. But I did get it to install 
finally, and here is how.

 After running 'apt-cache policy perl libnet-perl', which is a new trick for 
me, and I saw those Libranet entries, I commented them out of sources.list 
and tried again. Voila, worked like a charm. I really like Libranet, 'cause 
it's Real Debian with a great installer, but sometimes their sources are 
funky. They pull some from Experimental, and even daily snapshots.

Carla Schroder
this message brought to you
by Libranet 2.8 and Kmail

Reply to: