[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#706656: ITP: cura -- Controller for 3D printers

[Gregor Riepl]
> For some very strange reason, I don't see this SEGFAULT when I run the build
> process in a 32-bit VM on an amd64 system. Valgrind doesn't report any errors
> either.

The cause was incorrect use of sprintf() with int64_t.  I've added patches
for this to the latest upload, see
<URL: https://anonscm.debian.org/cgit/3dprinter/packages/cura-engine.git/tree/debian/patches >.

I've since been told that upstream solved it differently, by moving away
from int64_t to int32_t.  I have no idea if that is a better way to handle
it, but guess we will get that approach as soon as we update to a new
upstream version.

I've just uploaded libsavitar to NEW, after giving the d/copyright file a close
look.  I am aware of the several proposals for improvements, but concluded
that those can be uploaded next time, and decided it was more important
to get a slot in the NEW queue for now.

The only packages left now are uranium and cura.

Happy hacking
Petter Reinholdtsen

Reply to: