[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#659440: bumblebee packaging

On Mon, Jan 21, 2013 at 1:36 AM, Aron Xu <happyaron.xu@gmail.com> wrote:
> Hi Vincent,
> On Mon, Jan 21, 2013 at 5:12 PM, Vincent Cheng <vincentc1208@gmail.com> wrote:
>> Hi Aron,
>> On Sat, Jan 19, 2013 at 9:24 AM, Aron Xu <happyaron.xu@gmail.com> wrote:
>>> Hi,
>>> I've made some progress on bumblebee and pushed to pkg-nvidia repo:
>>> http://anonscm.debian.org/gitweb/?p=pkg-nvidia/bumblebee.git
>>> But because it's late here I can't test it now, if anyone can try it
>>> please let me know your results, thanks!
>> I've made a number of small changes to take into account certain
>> differences between Debian and Ubuntu's packaging of nvidia's
>> proprietary drivers [1][2] and added an udev rule to fix a bug [3].
>> Also cleaned up a few lintian tags (patch headers, and added a spiffy
>> new watch file).
>> I haven't actually tried installing those packages yet, but I'll try
>> to get to that asap (on a slightly unrelated note, I'll also try to
>> clean up my primus packaging a bit and get that uploaded too).
> Thanks for your work, I've tested my previous version on Debian Wheezy
> with a T420 Laptop, and it works as expected, using sysvinit and
> systemd, 3.2 and 3.7 kernels, all of them are ok. I tried to install
> my version of bbswitch and bumblebee on Ubuntu, but it appears that
> upstart needs more tuning, which I haven't worked on yet. If you have
> interest in it please have a try.

Assuming that you're also using the proprietary nvidia drivers, I'm a
bit surprised that your previous version (before I added my commits to
the git repo, right?) of bumblebee's packaging works on your Debian
laptop. The most important difference between the PPA and Igor's
packaging is in bumblebee-nvidia's postinst:

# update-alternatives --set $arch_gl_conf /usr/lib/$arch/mesa/ld.so.conf

Igor's debian bumblebee repo (suwako.nomanga.net):
# update-alternatives --set glx /usr/lib/mesa-diverted

Assuming you haven't manually run update-alternatives to divert the
glx symlink from /usr/lib/nvidia -> /usr/lib/mesa-diverted
(/usr/lib/nvidia has a higher priority than mesa-diverted), which for
the record is also mentioned on the Bumblebee page of Debian's wiki
[1], your intel graphics card would be trying to use nvidia's libGL
instead of mesa's implementation, and you'd lose 3D acceleration.
Debian's alternatives system doesn't have $arch_gl_conf, so the Ubuntu
PPA's postinst (and your previous packaging) would fail to correctly
divert libGL in Debian. (Unless I'm horribly mistaken and/or
overlooked something in your packaging?)

Just curious, what's the output of "sudo update-alternatives --display
glx" and "glxinfo" on your laptop?

Anyways, right now I'm hitting a strange bug with the packages I
built; dpkg just seems to hang while installing bumblebee and
bumblebee-nvidia, i.e.:
$ sudo dpkg -i bumblebee_3.0.1-1_amd64.deb bumblebee-nvidia_3.0.1-1_amd64.deb
(Reading database ... 398188 files and directories currently installed.)
Preparing to replace bumblebee 3.0.1-1 (using bumblebee_3.0.1-1_amd64.deb) ...
[ ok ] Stopping Bumblebee daemon: bumblebeed.
Unpacking replacement bumblebee ...
Preparing to replace bumblebee-nvidia 3.0.1-1 (using
bumblebee-nvidia_3.0.1-1_amd64.deb) ...
Unpacking replacement bumblebee-nvidia ...
Setting up bumblebee (3.0.1-1) ...
Installing new version of config file /etc/init.d/bumblebeed ...
update-initramfs: deferring update (trigger activated)
<...seems to get stuck here>

(Reproducible with the packaging after I committed my changes, and
with only your changes instead.)

Poking around with ps tells me that the show stopper is "/bin/sh
/var/lib/dpkg/info/bumblebee.postinst configure 3.0.1-1", hence
something about bumblebee's postinst script is causing me some
trouble, but then again Igor's Debian bumblebee packages work fine:

$ sudo apt-get install bumblebee bumblebee-nvidia
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  bumblebee bumblebee-nvidia
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/62.0 kB of archives.
After this operation, 246 kB of additional disk space will be used.
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
Selecting previously unselected package bumblebee.
(Reading database ... 398161 files and directories currently installed.)
Unpacking bumblebee (from .../bumblebee_3.0.1-1_amd64.deb) ...
Selecting previously unselected package bumblebee-nvidia.
Unpacking bumblebee-nvidia (from .../bumblebee-nvidia_3.0.1-1_all.deb) ...
Processing triggers for man-db ...
Setting up bumblebee (3.0.1-1) ...
[ ok ] Starting Bumblebee daemon: bumblebeed.
Setting up bumblebee-nvidia (3.0.1-1) ...
update-alternatives: using /usr/lib/mesa-diverted to provide
/usr/lib/glx (glx) in manual mode

I'll take another look at this tomorrow, but for now I just want to go
to bed. :)


[1] http://wiki.debian.org/Bumblebee#Driver_choice

Reply to: