[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#610676: One packaging of php-codecoverage

Hi Arthur

On Fri, Jan 28, 2011 at 02:50:47PM +0100, Arthur Gautier wrote:
> let me know if it can help

Sure, do you wanna co-maintain the package? I was doing a package too
but it's better to join forces :)

I just build and install your package but phpunit is still unusable,
here is why:

debian:/tmp# phpunit 
PHP Warning:  require_once(File/Iterator/Factory.php): failed to open stream: No such file or directory in /usr/share/php/PHP/CodeCoverage/Filter.php on line 46
PHP Fatal error:  require_once(): Failed opening required 'File/Iterator/Factory.php'
(include_path='.:/usr/share/php:/usr/share/pear') in /usr/share/php/PHP/CodeCoverage/Filter.php on line 46

I discover that php-codecoverage needs:
* PHP_TokenStream-1.0.1
* File_Iterator-1.2.3
* Text_Template-1.1.0
All of it from phpunit.de pear channel.

Also when i install them using PEAR, it also downloads:
* Base-1.8
* ConsoleTools-1.6.1
From components.ez.no PEAR channel

So we need to package at least the other three packages from phpunit.de.
I ask in ez's irc channel and seems that ConsoleTools and Base are not
needed in order to run PHP_CodeCoverage, but i didn't check it yet. I
expect to do that this weekend. After that i will create the ITPs and
start working.

Thanks for your work!


Attachment: signature.asc
Description: Digital signature

Reply to: