[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#519752: Please upload pysolfc to debian

On Thu, 16 Sep 2010, Bernhard Reiter wrote:

One problem, I added

Replaces: pysol
Conflicts: pysol, pysol-cardsets

fields to pysolfc, which would somehow collide with that transitional
pysol. I've tentatively added (<< 2.0-1~) to those field entries, but
unfortunately, latest pysol versions were higher (e.g. 4.40-3) than
current pysolfc (which would be 2.0-1). How do I proceed?

Two choices:


pysol and pysolfc don't have to be the same version.

pysol (the transitional) must have a version number greater than any that have ever been uploaded. So use version 8.82.2.

Then for pysolfc do:

Replaces: pysol (<< 8.82.2)
Conflicts: pysol (<< 8.82.2), pysol-cardsets, pysol-sounds, pysol-sound-server

And include an empty, separate, package for pysol. (i.e. pysol should not be part of the same source as pysolfc).

(Note the extra packages I added to the conflicts.)

Choice 2:

Use the epoch field of versions http://www.debian.org/doc/debian-policy/ch-controlfields.html#s-f-Version

i.e. pysolfc would be version 1:2.0-1 which is a higher version than 8.82.2.

Then do the rest as above, except pysol is part of the same package as pysolfc.

I believe this is not as good since it's not really what epoch is meant for.

So I suggest choice 1.


Reply to: