[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#524998: ITP: libmqdb-perl -- MappedQueryDB toolkit for federated databases



Charles Plessy <plessy@debian.org> (21/04/2009):
> > >   libdbd-sqlite3-perl (>= 1.14), libdbi-perl (>= 1.51), perl (>= 5.6.0-12)
> >                                                           ^^^^^^^^^^^^^^^^^^
> > WTH?
> 
> aqwa『~』$ zgrep -A1 -B1 '5.6.0-12' /usr/share/doc/dh-make-perl/changelog.gz 
>   * when module has no specific perl version requirements, fall back to "perl
>     (>= 5.6.0-12)" for B-D-I, like dh_perl. Remove retrieval of (now unised)
>     information about the available perl version.

Well.

One:
| $ rmadison -s oldstable perl
|     perl | 5.8.8-7etch6 |     oldstable | source, alpha, amd64, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc

Two, grepping debhelper's history:
| +# the installation dir for arch-indep modules changed to
| +# /usr/share/perl5 in this version:
| +my $min_version = '5.6.0-16';

Looks like it?
| commit b352136551fb3384722942f0206419ca066dedda
| Author: joey <joey>
| Date:   Wed Apr 25 17:01:49 2001 +0000
                              ^^^^
some years ago…
| 
|     r463:    * dh_perl: updates from bod:
|          - Provide minimum version for arch-indep module dependencies
|            (perl-policy 1,18, section 3.4.1).
|          - Always update substvars, even if Perl:Depends is empty.

Also, you already have perl-base and perl-modules, that might look like
sufficient? (And perl through debhelper anyway.)

Mraw,
KiBi.

Attachment: signature.asc
Description: Digital signature


Reply to: