[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#505877: ITP: jakarta-jmeter -- Load testing and performance measurement application.



On Thu, Mar 19, 2009 at 4:51 PM, Jan Wagner <waja@cyconet.org> wrote:
> Hi Onkar,
>
> is there any process? :)
>
> On Saturday 27 December 2008, Onkar Shinde wrote:
>> 1. I need sponsorship to the update of libcommons-jexl-java. The
>> updated packaging lies in pkg-java svn.
>
> Maybe you should write about this issue to
> pkg-java-maintainers@lists.alioth.debian.org ?

I had written 3 times previously but didn't get any response probably
because unstable was frozen.

>> 2. I will need to package excalibur-logger [1] as it is essential
>> dependency of jmeter.
>
> I didn't found an ITP here, so I guess there is no process.

I was working on this in Ubuntu, but found out that it didn't build
with logkit available in repositories. So I first need to update
logkit.

>> I plan to get everything done in Ubuntu first, as I have upload rights
>> there. After that I will port the package to Debian.
>
> Even having a look into https://launchpad.net/~onkarshinde/+related-software
> doen't indicate any news.

Actually I have packaged one dependency jcharts which is required by
all the reporting modules in jmeter. This needs to be ported to
Debian. I will ask people on pkg-java.

So the conclusion is that for Jmeter to enter in Debian:
1. libcommons-jexl-java needs to be updated
2. jcharts needs to be ported from Ubuntu.
3. logkit needs to be updated (actually excalibur-logkit needs to be
packaged so we don't affect rdepends of logkit.)
4. excalibur-logger needs to be packaged.

That is lot of work. :-)


Onkar



Reply to: