[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#384743: ITP: lua5.1-policy -- lua5.1 policy for debian packages

Package: wnpp
Severity: wishlist
Owner: Enrico Tassi <gareuselesinge@debian.org>

* Package name    : lua5.1-policy
  Version         : 1
  Upstream Author : Enrico Tassi <gareuselesinge@debian.org>
* URL             : http://alioth.debian.org/projects/pkg-lua/
* License         : MIT/X
  Programming Lang: make, bash
  Description     : lua5.1 policy for debian packages

This will include lua5.1-policy and lua5.1-policy-dev.

lua5.1-policy contains the policy (in txt and html format) that should
be followed by libraries for the lua5.1 scripting language.

lua5.1-policy-dev includes some template/support files (Like a generic
Makefile, a generic test application...) that are used by lua libraries
at compile time (so the will build-depend on it). It also includes a
simple script that sets up an svn directory conforming to
svn-buildpackage and populates it with the standard files needed to use
lua5.1-policy-dev at build time. Obviously packages made using
lua5.1-policy-dev will conform to the policy contained in lua5.1-policy.

An already working package can be found here:

And the following packages are all using this system:

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17-1-amd64-k8
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Reply to: