[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#353641: RFP: gaim-plugins -- 28 useful plugins for the Gaim instant messenger

Package: wnpp
Severity: wishlist

It would be great any or all of these useful gaim plugins could be
packaged for Debian.
I assume they could all go in one single package called gaim-plugins with the
version number of the version of gaim they are built against, since:
A) Plugins are easy to disable in the Gaim prefs dialog. B) If it was
all a single package,
I guess it'd be easier to rebuild the package against a newer version
of Gaim if
this was ever necessary.

gaim-osd 1.0.0-1
- prints incoming messages and other information at the bottom of your screen
- font size, auto-disable when you're at your PC, and more are configurable
src: http://sourceforge.net/project/showfiles.php?group_id=51563

Extended Preferences 0.5
- lets you change Gaim UI's font size
- lets you make other UI tweaks
src: http://sourceforge.net/project/showfiles.php?group_id=107659

SmartEar 1.0.0
- lets you set up custom notification sounds representing each of your friends
- lets you specify that sounds should be played no more often than N seconds
src: http://somewhere.fscked.org/smartear/#download

Gaim Plugin Pack 1.0beta2
- 24 plugins, though some may or may not be built in the Debian package:
- buddynote - Store local notes about a buddy.
- lastseen - Shows how long since a buddy was last online and the last
message you recieved from the buddy in the buddy's tooltip.
- markerline - Draws a line beneath the last read text in a
conversation/chat so you have a visual clue where you stopped
following the conversation.
- newline - Prepends a newline to the beginning of every message
written to a conversation so that the screen name or alias of a buddy
appears on a separate line from the message.
- stocker - Adds a stock ticker to the buddy list; this is similar to
the stock ticker found in Windows AIM.
- Many more: aadium_xml_logger, bit (Buddy Icon Tools), blistops
(Buddy List Options),
buzzer, dice, flip, Gaim-XChat, gRIM, groupmsg (Group Message),
irssidate, listhandler, mystatusbox,
nicksaid, oldlogger, sepandtab (Separate and Tab), showoffline,
simfix, sslinfo, talkfilters
- see homepage for details:
src: http://guifications.sourceforge.net/downloads.php

(still maintained; homepage mentions unfixed bugs)
- displays incoming IMs in the ratpoison window manager's message bar
src: http://linux.mikeasoft.com/ratgaim.tar.gz

I assume that if these plugins are compiled against Gaim 1.5.0 they
will still work when Gaim 2.0.0 is released into unstable and testing.
At http://www.student.cs.uwaterloo.ca/~kzorin/texim.php it says:
"Make sure that the gaim binary you use is as new or newer than the
gaim sources that you compile your plugins against. ... Gaim enforces
that if a plugin's version is later than your gaim version, it will
not show up in your gaim plugins list when you run the program."

If you would like to request more plugins as well, feel free to reply
to this bug and hope that they will be included as well.

Reply to: