[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

:Re: repeat of previous question thathasgoneunansweredseveraltimes.

On 5/12/23 07:41, Vincent Lefevre wrote:
On 2023-05-12 06:23:56 -0400, gene heskett wrote:
I'm confused. There is not anything wrong with this machine as a Server.
ALL of this muttering and bitching has been because bookworm clients did NOT
work. buster clients work great.

How many times do I have to say it is/was a CLIENT problem that only exists
for BOOKWORM clients.  The elephant in the room that most have ignored.

But you said that the problem was "solved" by modifying a setting
corresponding to the Listen directives (in /etc/cups/cupsd.conf).
These directives concern the *server* only.

Oh, then how does one tell the CLIENT to even use the SERVER? That statement, added to a created CLIENT.CONF, is not sufficient, Been tried many times. It does log a lack of auth, also reported here. Is that the real problem? The lack of any tracing info in the log, even at debug2 level reporting is a huge hindrance to intelligent trouble shooting.

I suspect that your problem was solved for another reason (e.g.
something else occurred on the network in the mean time, or some
config was reloaded at the right time, possibly as a consequence
of your testing). Or perhaps it is not solved at all and could
reappear in the future (that's why it would be interesting to
know the real cause of the problem).

copied new cup-master.zip to the bpi51
unpacked it to cups-master in ~/gene/src
./configure --with-tls=no, no show-stoppers.
make no-show stoppers
make test, failed for 2 functions
the report said at one place it got 34 errors but only expected 33
I didn't install

Back to the apple version installed, what fixed the bpi54 ddoes not fix the bpi51, so Vincent was right to be concerned

It is 100% a "cannot assign requested address error" on the bpi51 as logged in/var/log/cups/error_log:

E [12/May/2023:10:32:20 -0500] Unable to open listen socket for address - Cannot assign requested address. E [12/May/2023:10:34:45 -0500] Unable to open listen socket for address [v1.::1]:631 - Cannot assign requested address.

Where its getting the ipv6 addy is a mystery

ip a:
gene@bpi51:~/src/cups-master$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000 link/ether ae:c8:46:2e:6b:6b brd ff:ff:ff:ff:ff:ff permaddr da:0e:c7:cf:52:52
    inet 192.168.nn.y/24 brd 192.168.nn.255 scope global noprefixroute eth0
       valid_lft forever preferred_lft forever

ip r:
gene@bpi51:~/src/cups-master$ ip r
default via 192.168.nn.y dev eth0 proto static metric 100 dev eth0 scope link metric 1000
192.168.nn.y/24 dev eth0 proto kernel scope link src 192.168.nn.y metric 100

So, how can we proceed?

Cheers, Gene Heskett.
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author, 1940)
If we desire respect for the law, we must first make the law respectable.
 - Louis D. Brandeis
Genes Web page <http://geneslinuxbox.net:6309/>

Reply to: