[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing Debian Buster on Cubox-i4 with eSATA drive.

On 28/1/21 12:03 pm, Rick Thomas wrote:
I'm trying to install Debian Buster [1] on my Cubox-i4P with an eSATA drive. Everything seems to be fine, but when it comes time to reboot, it boots into the installer again, rather than the installed system.

Here's what I did, and what I observed:

*) I downloaded the two parts of the SDcard install image from [1] and followed the instructions in the README to create a 4GB (I didn't have anything smaller) SDcard installer.
*) I connected the eSATA disk and plugged the SDcard into the Cubox and powered it up.
*) It booted off the SD-card into the installer as expected.
*) Everything went as expected, until it got to the partition-disks phase.
*) I chose to use the eSATA disk as the installation target.  I told it to use the whole disk and use the LVM method of partitioning.
*) It created the /boot ext2 partition in /dev/sda1 and put root, /home and swap in the LVM on /dev/sda5.  This is (I think) exactly what I wanted.
*) There was no mention of the SDcard /dev/mmcblk1 (except when initially choosing the target disk -- I did explicitly NOT choose it at this time)
*) I allowed it to wipe and re-partition the eSATA disk, which it did without incident.
*) Everything proceeded as expected.  I chose a minimal (ssh and base packages) in tasksel.
*) When it came to "make it bootable" I said go ahead.  There was no mention of /dev/mmcblk1 at this stage.
*) It proceeded from there without any apparent errors.
*) When it came time to reboot, I said go ahead.
*) But when the reboot happened, I found myself back in the installer.
*) I tried removing the SDcard and rebooting, but it failed to boot -- after power-on nothing happened.

What I hoped would happen with the eSATA drive was that the installer would write the boot firmware (u-boot, etc) to the SDcard, and configure it to get /boot, root, /home, swap off the eSATA.

What I suspect has happened is that the boot firmware (u-boot, etc) was written to the eSATA drive and so it can't be found by the power-up routine without some reconfiguration to tell it to look at the eSATA, but that isn't happening.

Anybody know what I can do to either:
1) Tell the power-up routines to look at the eSATA?
2) Write the boot firmware to the SD card and configure it to get the rest of the system from the eSATA?

Debug logs were saved, and can be provided upon request.

Thanks in advance for any help!

PS:   In a previous attempt, I used a 64GB SDcard without the eSATA disk -- putting everything onto the SDcard.  That worked fine (It put the boot stuff on the SDcard) but it's horribly slow due to the very low speed of data transfer to and from the SDcard.

[1] http://http.us.debian.org/debian/dists/bullseye/main/installer-armhf/current/images/netboot/SD-card-images/

I think you'll find the device can't boot off e-SATA. The normal work-around is to have an initial SD or USB device with /boot only that does the first stage of the boot and then uses the eSATA file system for the subsequent stages.

This process is automated in some distros such as Armbian. I have used this process with the FriendlyElec NanoPi M4V2 which has an M.2 PCIE drive


Attachment: OpenPGP_signature
Description: OpenPGP digital signature

Reply to: