[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem with wget -O

On Mon, Jan 25, 2021 at 04:07:33PM -0500, Gene Heskett wrote:
> gene@coyote:~/src/build$ cd .. && wget -O opencv.zip https://github.com/opencv/opencv/archive/master.zip
> Cannot specify both -k or --convert-file-only and -O if multiple URLs are given, or in combination
> with -p or -r. See the manual for details.
> Usage: wget [OPTION]... [URL]...

I tried to duplicate this myself, using buster, and using stretch (as
you previously reported this is on stretch).  I was not able to do so
using only modifications of the command you gave.  I tried replacing the
space after -O with a non-breaking space, and I tried using -O -opencv.zip
(hinted by the -p in the error message).

My next guess is that perhaps wget is receiving additional options from
somewhere other than your command line.  Perhaps via an environment
variable, or something.

Apparently wget doesn't have any such env vars, but it does allow a
startup file, which it calls ".wgetrc".  Or /etc/wgetrc.

So, after reading up on that, and experimenting a bit:

unicorn:/tmp/build$ cat ~/.wgetrc
convert-links = on
page-requisites = on

If I create a ~/.wgetrc file with at least those two lines in it, then
I get the same error you got.

Do you have a ~/.wgetrc file?  If so, what's in it?  If not, what's in
your /etc/wgetrc file (other than comments and blank lines)?

Reply to: