[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Burn Blu-Ray video on Linux

Bob McGowan wrote:

> Hi,
> I have a high def (4K) mp4 video I would like to put on a Blu-Ray disk,
> to play in a standard Blu-Ray player.
> So I did the Google search and found several posts, all of which
> mentioned an application tsMuxeR, which is available for Linux and is in
> the Debian repos.
> However, it is a 32 bit application, but hey, no problem, I have
> multi-arch configured, and I've been able to run some 32 bit apps
> without issues.
> Except this one.  The ldd command (is it ok to use the 64 bit command on
> a 32 bit binary?) says the file is "not a dynamic executable", yet when
> I run it, it complains about libraries not being found (which probably
> answers the question about ldd):
> tsMuxeR: error while loading shared libraries: libstdc++.so.6:
> But:
>  $ find /usr/lib* -name libstdc++\*
>  /usr/lib/gcc/x86_64-linux-gnu/6/libstdc++fs.a
>  /usr/lib/gcc/x86_64-linux-gnu/6/libstdc++.a
>  /usr/lib/gcc/x86_64-linux-gnu/6/libstdc++.so
>  /usr/lib/x86_64-linux-gnu/libstdc++.so.6
>  /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.22
>  /usr/lib64/libstdc++.so.6.0.22
>  /usr/lib64/libstdc++.so.6
>  /usr/libx32/libstdc++.so.6.0.22
>  /usr/libx32/libstdc++.so.6
> Only one directory in the above with 32 bit, so I tried adding it to
>  $ LD_LIBRARY_PATH=/usr/libx32 tsMuxeR
>  tsMuxeR: error while loading shared libraries: libstdc++.so.6:
> No joy.  And there is no file matching libstdc++.so.6 in /lib* or
> /usr/local/lib, either
> Have I misconfigured something with multi-arch?  Is there a bug I
> couldn't find a reference too?
> Any help or suggestions on other software to try?
> Thanks,
> Bob

The libcstdc++ you need should be in stretch

ii  libstdc++6:i386                         6.3.0-18+deb9u1                            
i386         GNU Standard C++ Library v3

it provides

The /usr/libx32/libstdc++.so.6.0.22 is probably artefact from the past


Reply to: