[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cannot open display: localhost:0.0 [solved]

Hi there

On 23/09/2018 20:07, Grzesiek Sójka wrote:

On 9/23/18 2:36 PM, Rob van der Putten wrote:

On 23/09/2018 13:48, Grzegorz Sójka wrote:

I need to allow remote applications to connect to xorg. Since I log in using lxdm i have tcp_listen=1 in /etc/lxdm/lxdm.conf. Thus Xorg is running without -nolisten tcp flag. Unfortunately:

$ xhost +localhost; DISPLAY=localhost:0.0 xterm
localhost being added to access control list
xterm: Xt error: Can't open display: localhost:0.0

Any suggestions??

Did you check port 6000?
root@pc6:~# netstat -anp | grep 6000
tcp   0   0*   LISTEN   2684/Xorg
tcp6  0   0 :::6000        :::*        LISTEN   2684/Xorg

Bingo! The command gave me empty output.

Always start low level.

Now -nolisten tcp is the default Xorg behaviour. Thus, you need to add -listen tcp flag explicitly.

That changed some time ago.

I added:
arg=/usr/bin/X -background vt07 -listen tcp
to /etc/lxdm/lxdm.conf and now it works perfectly.

Sometimes it's in /etc/X11/xdm/Xservers or /etc/X11/xinit/xserverrc
With lightdm it's in /etc/lightdm/lightdm.conf;


Reply to: