[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Buster: "cannot run in framebuffer mode"

I have two different Debian Buster/sid systems. The first is a desktop PC with AMD RX 580 graphics. It used to work ok until July, then I updated it sometime in August, and Xorg broke.

The second is an Acer Aspire5 notebook I've just bought, with AMD RX 540 graphics. I've installed Debian using the latest Debian Buster testing ISO (August 27th, as today's one wasn't available yet), and Xorg doesn't start.

Both Xorg.0.log show the same error:

Fatal server error:
Cannot run in framebuffer mode please supply the busIds for all framebuffer devices

Both systems run the 4.17 amd64 kernel, but I've also tried a custom 4.18 kernel on the desktop system, with the same results.

I could find a number of references to that error out there, but all of them point either to a solution that does not work in my cases (e.g. adding "amdgpu.cik_support=1 radeon.cik_support=0" to the kernel comdline) or to a old and already closed bug report, (e.g. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=508476)

I'd suspect fbdev was somehow guilty, but the fbdev module isn't even listed by lsmod.

I've already tried creating a /etc/X11/xorg.conf file, using

# Xorg -configure

but it didn't solve the problem.

Any clues?

Reply to: