[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

adaptec raid controllers (ASR71605Q, module: aacraid) fail to boot with xen hypervisor 4.8 or 4.10

Hi list,

I tried to upgrade some servers this weekend, but failed in my attempts.
the hardware differs except in one component, they all have a Adaptec
raid controller of the 7th generation (ASR71605Q to be specific, using
kernel module accraid).

With debian jessie everything was fine, but upgrading to stretch the
kernel module is unable to initialize the raid controller.

The system seems to be able to init other cards (ie. a pcie Adaptec UW
SCSI Controller) but initializing the ASR71605Q fails with:

aacraid: aac_fib_send - first asynchronous command timed out


aacraid: Host adapter abort request (0,0,1,0)
aacraid: Host adapter abort request (0,0,116,0)
aacraid: Host adapter abort request (0,0,119,0)

on the second system (first is a classic bios machine, second is uefi)

Then at some point the system gives up, root device fails, and you end
up in initramfs.

Booting without xen hypervisor works just fine.

I tried different kernel versions, the old one (3.16) and a current
stretch backports (4.17.8) with the same result: No raid controller,
when running xen.

I also tried xen 4.10: No raid controller.

Also tried upgrading controller and mainboard firmware and the latest
aacraid kernel module from adaptec instead of the original kernel
modules, but nothing seems to help.

I've found several posts in ubuntu (and centos, I think) mailing lists
of the last two years, with people having the same issues, but no
solution except not upgrading. They all have some Adaptec raid
controller using aacraid and try to upgrade from xen ~4.4 to something
newer and they all can boot normally without xen. Some posts suggest
that that the 8th generation is also affected.

A more current card (Adaptec SmartRAID 3154-16i using kernel module
smartpqi) seems to work fine.

My guess would be that something is wrong with the more recent
hypervisor versions.

Anyone seen this behavior before?


Reply to: