[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Please help with error message



	Hi.

On Tue, Aug 07, 2018 at 09:05:28AM +0200, Rodolfo Medina wrote:
> Some little problems after `full-upgrade' to Sid: no sound...  Besides, when
> trying to install new packages, the following message appears:
> 
> # aptitude install alsaplayer-alsa pulseaudio 
> pulseaudio is already installed at the requested version (12.0-1)
> pulseaudio is already installed at the requested version (12.0-1)
> The following NEW packages will be installed:
>   alsaplayer-alsa alsaplayer-common{a} alsaplayer-gtk{a} libmikmod3{a} 
> 0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
> Need to get 0 B/505 kB of archives. After unpacking 1,410 kB will be used.
> Do you want to continue? [Y/n/?] y
> dpkg: warning: 'ldconfig' not found in PATH or not executable
> dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
> dpkg: error: 2 expected programs not found in PATH or not executable
> Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
> E: Sub-process /usr/bin/dpkg returned an error code (2)
> dpkg: warning: 'ldconfig' not found in PATH or not executable
> dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
> dpkg: error: 2 expected programs not found in PATH or not executable
> Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
> 
> Please help...  I'm not expert.

Your installation lacks /sbin/ldconfig and /sbin/start-stop-daemon from
"libc-bin" and "dpkg" packages respectively. Or root's $PATH lack
"/sbin" somehow.
Either way it's not normal, it's a little wonder that you're able to
boot or run any binary executable.


I'd start fixing this mess by checking root's $PATH:

echo $PATH

It literally should have this value:

/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

Next I'd try this:

apt-get install --reinstall dpkg libc-bin

Reco


Reply to: