[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: exim4 and TLS Once Again

	The problem (actually 2 problems) are solved.

	The one I was actually posting about turned out to be
that I had put a line which says 

protocol = smtps

in the wrong place in a file named

	This caused dpkg-reconfigure exim4-config to throw an
error about not being able to generate the master configuration
file named /var/lib/exim4/config.autogenerated.

It turns out that it's the very last line in the file just as it
was before and I had seen where I thought it should go which was

	After that, the login worked.  Port 465 is supposed to
start encrypted and 587 starts in the clear.

	What I found out, though, was that there was another
issue, that of the user id that suddenlink needs to see versus
the user ID based totally on the user and machine name.

	There is a specific debian fix for this problem which
makes life light years easier and it is


and it installs along with your debian version of exim4 and
starts life empty of anything but comments and explanation.

	One simply puts in a line containing their local user ID
followed by a : and then the user ID that the smarthost knows you

	exim4 rewrites all the local lines such as Sender: to be
the remote user ID and then you can start your happy dance
because it just works.

	You can have multiple smarthosts and multiple lines in
/etc/email-addresses so if there are multiple users on the debian
system or you have multiple smarthosts to deliver to, the user ID
that gets sent over the network is right each time.

	This is getting easier with each upgrade but you need to
stick to very recent postings to get the best information.

	Anyway, it now works again and I am simply sending it through
exim4 in the normal manner.

Thank you to everybody who helped.
Martin McCormick WB5AGZ

Reply to: