[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lightdm (testing): Long waiting time after login



This time with attachment...

Am 16.05.2018 um 09:28 schrieb work@hllmnn.de:

I just did a fresh install of testing with XFCE. After entering the login credentials the screen was black for 30-60 seconds before the desktop environment showed up. Assuming a bug in XFCE, I performed another fresh install with MATE, but a similar effect occured: after login the background image is shown for 30-60 seconds before the desktop is fully loaded.

A look into /var/log/lightdm/lightdm.log showed that the delay happens before VT is activated. The log file is attached.

Might this be a bug in lightdm or could a misconfiguragtion from my side cause this issue?

Best,
Dino


[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.18.3, UID=0 PID=595
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/01_debian.conf
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Registered seat module xlocal
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.06s] DEBUG: Monitoring logind for seats
[+0.06s] DEBUG: New seat added from logind: seat0
[+0.06s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.06s] DEBUG: Seat seat0: Starting
[+0.06s] DEBUG: Seat seat0: Creating greeter session
[+0.07s] DEBUG: Seat seat0: Creating display server of type x
[+0.07s] DEBUG: Could not run plymouth --ping: Failed to execute child process â??plymouthâ?? (No such file or directory)
[+0.07s] DEBUG: Using VT 7
[+0.07s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.07s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+0.07s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+0.07s] DEBUG: DisplayServer x-0: Launching X Server
[+0.07s] DEBUG: Launching process 610: /usr/bin/X :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.07s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+0.07s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.07s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.08s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.08s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+1.42s] DEBUG: Got signal 10 from process 610
[+1.42s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+1.42s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+1.48s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+1.48s] DEBUG: Session pid=637: Started with service 'lightdm-greeter', username 'lightdm'
[+1.52s] DEBUG: Session pid=637: Authentication complete with return value 0: Success
[+1.52s] DEBUG: Seat seat0: Session authenticated, running command
[+1.52s] DEBUG: Session pid=637: Running command /usr/sbin/lightdm-gtk-greeter
[+1.52s] DEBUG: Creating shared data directory /var/lib/lightdm/data/lightdm
[+1.52s] DEBUG: Session pid=637: Logging to /var/log/lightdm/seat0-greeter.log
[+1.69s] DEBUG: Activating VT 7
[+1.69s] DEBUG: Activating login1 session c1
[+1.70s] DEBUG: Seat seat0 changes active session to c1
[+1.70s] DEBUG: Session c1 is already active
[+2.10s] DEBUG: Greeter connected version=1.18.3 resettable=false
[+3.22s] DEBUG: Greeter start authentication
[+3.22s] DEBUG: Session pid=689: Started with service 'lightdm', username '(null)'
[+3.24s] DEBUG: Session pid=689: Got 1 message(s) from PAM
[+3.24s] DEBUG: Prompt greeter with 1 message(s)
[+5.72s] DEBUG: Greeter start authentication for USERNAME
[+5.72s] DEBUG: Session pid=689: Sending SIGTERM
[+5.72s] DEBUG: Session pid=691: Started with service 'lightdm', username 'USERNAME'
[+5.72s] DEBUG: Session pid=689: Terminated with signal 15
[+5.72s] DEBUG: Session: Failed during authentication
[+5.72s] DEBUG: Seat seat0: Session stopped
[+5.73s] DEBUG: Session pid=691: Got 1 message(s) from PAM
[+5.73s] DEBUG: Prompt greeter with 1 message(s)
[+7.52s] DEBUG: Continue authentication
[+7.55s] DEBUG: Session pid=691: Authentication complete with return value 0: Success
[+7.55s] DEBUG: Authenticate result for user USERNAME: Success
[+7.55s] DEBUG: User USERNAME authorized
[+7.63s] DEBUG: Greeter requests session lightdm-xsession
[+7.63s] DEBUG: Seat seat0: Stopping greeter; display server will be re-used for user session
[+7.63s] DEBUG: Session pid=637: Sending SIGTERM
[+7.71s] DEBUG: Greeter closed communication channel
[+7.71s] DEBUG: Session pid=637: Exited with return value 0
[+7.71s] DEBUG: Seat seat0: Session stopped
[+7.71s] DEBUG: Seat seat0: Greeter stopped, running session
[+7.71s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
[+7.71s] DEBUG: Session pid=691: Running command /etc/X11/Xsession default
[+7.71s] DEBUG: Creating shared data directory /var/lib/lightdm/data/USERNAME
[+7.71s] DEBUG: Session pid=691: Logging to .xsession-errors
[+40.89s] DEBUG: Activating VT 7
[+40.89s] DEBUG: Activating login1 session 2
[+40.89s] DEBUG: Seat seat0 changes active session to 
[+40.89s] DEBUG: Seat seat0 changes active session to 2
[+40.89s] DEBUG: Session 2 is already active

Reply to: