[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem of expanded partition partially solved.

A mass of torment to subscribe to this list stay behind. The reason for the torment is ridiculous, the 'CONFIRM' for the subscription should be sent by pressing "Reply", but I as a donkey always opened a new message to send a 'CONFIRM''!

Problem of expanded partition partially solved. After used 'resize2fs /dev/sda' was instant appeared viewing free space with 'Thunar', and stopped:
---Command (m for help): w
The partition table has been altered.
Calling ioctl() to re-read partition table.
Re-reading the partition table failed.: Device or resource busy.
The kernel still uses the old table. The new table will be used at the next reboot or after you run partprobe(8) or kpartx(8)-----


----/user# fdisk /dev/sda 
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command----.

Here remained the 2-minute scanning 'sda' in booting, which not very bother for me, but a wish get rid of this are is. May be a try to rewrite 'etc/fstab' will be rightly? I don't hurry with this, because it is fog for me. See yourself:


-----/home/user# fdisk -l /dev/sda
Disk /dev/sda: 55.9 GiB, 60011642880 bytes, 117210240 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xd961d961

Device     Boot    Start      End  Sectors  Size Id Type
/dev/sda1             63 30723839 30723777 14.7G  7 HPFS/NTFS/exFAT
/dev/sda2  *    30724096 78125000 47400905 22.6G 83 Linux
/dev/sda3       78125056 83984383  5859328  2.8G 82 Linux swap / Solaris----


----home/user# parted /dev/sda print
Model: ATA FUJITSU MHT2060A (scsi)
Disk /dev/sda: 60.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32.3kB  15.7GB  15.7GB  primary  ntfs
 2      15.7GB  40.0GB  24.3GB  primary  ext4         boot
 3      40.0GB  43.0GB  3000MB  primary----,
                                             What to believe?

If someone prompts how to rewrite my 'fstab', it would be perfect.

----------# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=042db4cb-1d87-469b-bd41-2a8409196989 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda3 during installation
UUID=3a64784b-9807-446a-bc39-c9011ba6ed6b none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0---------------.

Thank all of you.

Reply to: