[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel problem?

On 01/06/2018 06:58 PM, Rob Hurle wrote:
Hi All,

   I'm running Stretch and yesterday I did my normal:

sudo apt-get update
sudo apt-get upgrade

It seemed to install vmlinuz-4.9.0-5-686-pae (and associated config and
image files, etc) in place of 4.9.0-4-686-pae versions.  Now the system
won't boot at all.  I have reverted to 4.9.0-4-686-pae and all is well.  My
questions are:

1.  Does anyone else see this?

2.  How can I revert without losing my working 4.9.0-4-686-pae system?  Can
I just change the soft links for initrd.img and vmlinuz at / to point to
the 4.9.0-4-686-pae versions instead of the 4.9.0-5-686-pae ones?  Will
this break something else for a future upgrade?

Any help much appreciated.  Thank you.

I had a problem with that kernel on first boot, so I booted the old kernel with no problem and then tried the new kernel again to see if I could get a hint at what the problem was and it booted and the desktop started with no problem and again with no problem, go figure..I'm still booting the new kernel(Linux jimmy-1 4.9.0-5-amd64 #1 SMP Debian 4.9.65-3+deb9u2 (2018-01-04) x86_64 GNU/Linux) with no problem. So if you have not tried to reboot with the new kernel, maybe cross your fingers and give it another try or two.

Jimmy Johnson

Debian Stretch - KDE Plasma 5.8.6 - AMD A8-7600 - EXT4 at sda6
Registered Linux User #380263

Reply to: