[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: vbox cannot find headers, although they are installed

On Saturday, January 6, 2018 8:36:38 PM -03 Harry Putnam wrote:
> Having a problem getting the vbox guest additions on a `testing'
> install to allow for larger monitor resolution.
> When I attempt to install the additions the ouput says it cannot find
> the headers for the running kernel.
> I have checked, rechecked and reinstalled the headers but still get
> the message that they cannot be found and the kernel module build then
> fails.
> (Note: All debian systems mentioned below are running as guests on an
> `openindiana' (a solaris offshoot) host)
> (Full output of attempted guest additions install are at the end)
> But briefly . . . .
> >From the host with the failure:
>   uname -r 4.14.0-2-amd64
This is not Stretch? Stretch is still with 4.9.0-5-amd64.
>   aptitude search headers |grep ^i
>   i  linux-headers-4.14.0-2-amd64 - Header files for Linux 4.14.0-2-amd64
>   i A linux-headers-4.14.0-2-common - Common header files for Linux 4.14.0-2
> ,----
> | On two other debian systems (both running stretch, not `testing')
> | everything works as expected and the kernel module build succeeds...
> | monitor settings then act accordingly.
> | 
> | From 2 stretch hosts:
> | Of course, it is a different kernel and headers (4.9.0-5-amd64) on the
> | `stretch' systems and with like named header files.
> | 
> |   i A linux-headers-4.9.0-5-common
> |   i A linux-headers-4.9.0-5-amd64
> | 
> | With those in place on the stretch systems the guest additions build
> | just like they should.
> `----
> What am I missing?

Did you by any chance install a kernel higher than 4.14.0-2 to check it out, 
then went back to 4.14.0-2 or installed 4.14.0 and then went back to 4.9.0?
In that case VBox is most probably still looking for the headers of the higher 
kernel version and cannot find them. I ran into that problem before.
In that case you will have to deinstall VBox completely and install it again. 
You can retain the virtual installations and later incorporate them into VBox 

> =================================================================
> Terminal output from attempting install of guest additions
> =================================================================
> [Did not post the full log referred to in the output below... it is
> very long... but I can post it if necessary]
> root # bash ./VBoxLinuxAdditions.run
> Verifying archive integrity... All good.
> Uncompressing VirtualBox 5.0.40 Guest Additions for Linux............
> VirtualBox Guest Additions installer
> Removing installed version 5.0.40 of VirtualBox Guest Additions...
> Removing existing VirtualBox non-DKMS kernel modules ...done.
> update-initramfs: Generating /boot/initrd.img-4.14.0-2-amd64
> Copying additional installer modules ...
> Installing additional modules ...
> Removing existing VirtualBox non-DKMS kernel modules ...done.
> Building the VirtualBox Guest Additions kernel modules
> The headers for the current running kernel were not found. If the following
> module compilation fails then this could be the reason.
> Building the main Guest Additions module ...fail!
> (Look at /var/log/vboxadd-install.log to find out what went wrong)
> Doing non-kernel setup of the Guest Additions ...done.

Reply to: