[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Live USB fails; bricks the USB stick

On 11/7/17, Kent West <westk@acu.edu> wrote:
> I wanted to create a Live Debian USB stick (using an existing Debian
> system). I remember doing such a few years ago with "unetbootin", but when
> I looked for "unetbootin" via aptitude search, I couldn't find it, so I did
> a quick "unetbootin debian" search, and found a Debian bug report from 2015
> (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=775689) that led me to
> believe I should not use unetbootin, but to use the newer method of simply
> dd'ing the .ISO to the USB drive.
> So I went to
> https://cdimage.debian.org/debian-cd/current-live/amd64/iso-hybrid/ and
> downloaded the AMD64 Cinnamon version of 9.2.0, and then inserted my USB
> stick, found it on /dev/sdc, and ran the command:
> sudo if=debian-live-9.2.0-amd64-cinnamon.iso
> <https://cdimage.debian.org/debian-cd/current-live/amd64/iso-hybrid/debian-live-9.2.0-amd64-cinnamon.iso>
>  of=/dev/sdc
> I walked away then and came back in a few minutes to find it had finished,
> but didn't pay attention to any other messages, and then tried booting it
> on another year-old Dell PC. It gave me the grub menu, but then when I
> tried to boot Debian Live, I got an error about an invalid magic number and
> a need to load a kernel first.
> Not finding any documentation that might help, I checked the md5sum on the
> downloaded file (it was correct), and tried the dd again. Same result.
> I tinkered a bit, and then the next time I tried a dd, I noticed that it
> was giving me an input/output error for /dev/sdc. Still, it seemed to
> finish properly, but the boot attempt gave the same failed result.
> So I decided to try a different download; I tried the Mate flavor. Same
> result.
> So I decided to try a different USB stick. Same result.
> And now, both my sticks are complaining about being mounted read-only, and
> I can't seem to fix that.
> I tried "hdparm -r0 /dev/sdc", and that reports that it's set the read-only
> flag to off, but the stick still is read-only.
> So it appears that dd'ing a Debian .iso to a USB stick, at least using my
> hardware, bricks the USB stick.
> I'm assuming my attempt has cost me two USB sticks, and has just left a bad
> experience with Debian under my belt, and there's nothing I can do about
> it. (I don't even know where a bug report might go.) But I thought I'd put
> this info on the User's list, just for the record, and perhaps at the
> chance that someone might have a solution.

Would something like parted or gparted help you manhandle both sticks
back into submission?

That magic number error, I've seen that in my usage before.

I'm getting a different one now, that 3 initial one, x/x/x, on an HDD
partition myself in last few days. That was from an rsync and tweak to
be bootable. #FAIL. There *are* fixes that I've successfully used in
the last year or so, but I got sidetracked and never tracked that back
down this last time.

But that readonly might put the kibosh on any hope at any kind of fix
in your case unless something like parted or gparted helps with that

Just thinking out loud (about something I might try).. :)

Cindy :)
Cindy-Sue Causey
Talking Rock, Pickens County, Georgia, USA

* runs with duct tape *

Reply to: