[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: systemd process(es) consuming CPU when laptop lid closed

You’re going to get an e-mail from me in ~10 hours or so saying I fixed it; for some reason, this mailing list is delaying my emails by about 24 hours. So much for speedy technology!


That certainly isn’t all from the output, it’s only an excerpt. My console was being absolutely spammed with output when I ran that command. As far as I could tell, they were mostly repeated. I could try to reproduce the issue and provide a larger sample if you wish. You had mentioned a log for this program too, is there one I could provide?


Thank you,




From: Michael Biebl
Sent: Monday, October 16, 2017 2:51 PM
To: debian-user@lists.debian.org
Subject: Re: systemd process(es) consuming CPU when laptop lid closed


Am 16.10.2017 um 02:56 schrieb Glen B:

> On 10/15/2017 10:31 AM, Michael Biebl wrote:

>> Am 14.10.2017 um 21:48 schrieb Glen B:

>>>    295 root      20   0    7448   4432   3992 R 41.2  0.9   0:54.81 systemd-logind

>>>    298 message+  20   0    6260   3636   3268 S 17.6  0.7   0:17.12 dbus-daemon

>> That looks like there is a huge amount of dbus messages sent.

>> Can you run dbus-monitor --system (as root) to see what those messages are?


> That's an interesting command, lots of information was spat out. Here's

> an excerpt of what was put out:


> ----

>   uint32 0

> error time=1508114297.985967 sender=:1.0 -> destination=:1.1

> error_name=org.freedesktop.systemd1.UnitMasked reply_serial=26352

>     string "Unit suspend.target is masked."

> signal time=1508114297.986032 sender=:1.0 -> destination=(null

> destination) serial=52814 path=/org/freedesktop/systemd1;

> interface=org.freedesktop.systemd1.Manager; member=UnitNew

>     string "suspend.target"

>     object path "/org/freedesktop/systemd1/unit/suspend_2etarget"

> signal time=1508114297.986058 sender=:1.0 -> destination=(null

> destination) serial=52815 path=/org/freedesktop/systemd1;

> interface=org.freedesktop.systemd1.Manager; member=UnitRemoved

>     string "suspend.target"

>     object path "/org/freedesktop/systemd1/unit/suspend_2etarget"

> signal time=1508114297.991185 sender=:1.1 -> destination=(null

> destination) serial=26353 path=/org/freedesktop/login1;

> interface=org.freedesktop.login1.Manager; member=PrepareForSleep

>     boolean true

> method call time=1508114297.992516 sender=:1.1 ->

> destination=org.freedesktop.systemd1 serial=26354

> path=/org/freedesktop/systemd1;

> interface=org.freedesktop.systemd1.Manager; member=StartUnit

>     string "suspend.target"

>     string "replace-irreversibly"

> method call time=1508114297.993237 sender=:1.0 ->

> destination=org.freedesktop.DBus serial=52816

> path=/org/freedesktop/DBus; interface=org.freedesktop.DBus;

> member=GetConnectionUnixUser

>     string ":1.1"

> method return time=1508114297.993292 sender=org.freedesktop.DBus ->

> destination=:1.0 serial=13188 reply_serial=52816

> ----


> If I'm understanding this correctly, it looks like it's trying to

> suspend but is somehow getting confused...


Not sure about the confused part. We might need a debug log for



That said, is that all? Given the high cpu usage for the dbus-daemon

process I was expecting it to be flooded by dbus messages.


You could also try stracing dbus-daemon and systemd-logind and see if

you get anything interesting.





Why is it that all of the instruments seeking intelligent life in the

universe are pointed away from Earth?



Reply to: