[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SOLVED - Re: xfce4-terminal fails to “pass through” environment variables

Hash: SHA1

On Mon, Oct 02, 2017 at 10:52:11PM +1100, Zenaan Harkness wrote:
> On Mon, Oct 02, 2017 at 01:38:07PM +0200, tomas@tuxteam.de wrote:
> > A couple of years ago or five, I switched back to xterm (from a random
> > walk which included gnome-terminal at some point). Xterm had fixed its
> > UTF-8 problems, could use modern fonts and all that.
> > 
> > Reading your accounts remimds me why I probably won't look back!
> I do have a soft spot in me heart for xterm - been using it for
> years. Only recently looked into xfce4-terminal due to its better
> font handling - at least after I made it look and act almost
> identically to xterm :)
> (Which included enabling fixed fonts.)
> (On xterm I use
> "-fn -misc-fixed-medium-r-normal--10-100-75-75-c-60-iso10646-1"
> but have also tried "-fa Fixed -fs 8"
> )
> I'm using font "Fixed SemiCondensed" 8 pt in xfce4-term - and it
> seems xfce4-terminal has some fallback to either some other font(s?)
> but in any case, displays all Unicode chars I've tried to display,
> whereas xterm fails on some chars I want to use. E.g.:
> ƒ ("function" symbol) displays fine in both xterm and xfce4-terminal

This one displays fine in my xterm...

> but
> ❴ and ❵ (mathematical braces) only displays in xfce term, and not
> xterm for a reason I have not been able to figure out.

... and those two too :)

FWIW I have

  tomas@rasputin:~$ cat .Xresources 
  *VT100.faceName:        Liberation Sans Mono
  *VT100.faceSize:        8
  *VT100.faceSize1:       3
  *VT100.faceSize2:       5
  *VT100.faceSize3:       8
  *VT100.faceSize4:       10
  *VT100.faceSize5:       14
  *VT100.faceSize6:       20

(yes, my screen is small, and I'm a tad short-sighted)

> Other than that, I've achieved almost identical colours, (font size
> and style), and keyboard shortcuts (enabled all the tabs and etc
> shortcuts in xfce term). xterm solved a bug some years back on font/
> buffer scrolling, and ever since it's been the zippiest terminal of
> all the ones I've tried, but I now need ‘full’ font support...

Given all the other shenanigans, I'd be willing to put with *some*
downsides, but at the moment I don't have even those ;-D

- -- t
Version: GnuPG v1.4.12 (GNU/Linux)


Reply to: