[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: there is gui but no login on console after boot

On Tue, 26 Sep 2017, Tamas Hegedus wrote:


Recently I have noticed that there is no login prompt on my consoles.
X11 starts and I can use my system (I can also start a gui console).

I have upgraded my system to Debian 9 and hoped to get this issue solved seamlessly. However, there is still no prompt.

It is unclear to me, from what you say, whether this problem arose
after the upgrade to stretch, or was also a problem in jessie, before
the upgrade.

Could you suggest how to debug such an issue?

Not me. Maybe somebody smart will chime in.

But until they do, I'll tell you 3 things I might try.

Thing 1:

There is some information of interest in the "Virtual Terminals"
section of this discussion:


The last paragraph of that section says:

| Secondly, tty6 is especially reserved for auto-spawned gettys and
| unavailable to other subsystems such as X. This is done in order to
| ensure that there's always a way to get a text login, even if due to
| fast user switching X took possession of more than 5 VTs.

So you might check whether tty6, in particular, is available. Do
Ctrl-Alt-F6, and see if you get a login prompt.

Thing 2:

If that doesn't work, I wonder what files you see in
/etc/systemd/system/getty.target.wants/ ?

 $ ls /etc/systemd/system/getty.target.wants

You could ask systemd to, from now on, prepare some more VTs at boot
by soft-linking lib/systemd/system/getty@.service into that directory.

As root, to arrange for a VT on tty2, you could do...

 # DESTDIR=/etc/systemd/system/getty.target.wants
 # ln -s /lib/systemd/system/getty\@.service $DESTDIR/getty\@tty2.service

...and so on, for tty3, tty4, etc...

 # ln -s /lib/systemd/system/getty\@.service $DESTDIR/getty\@tty3.service
 # ln -s /lib/systemd/system/getty\@.service $DESTDIR/getty\@tty4.service

Thing 3:

If you don't want to wait for reboot, don't feel like making big plans
for the future, and just want a VT now, as root do something like

 # systemctl enable getty@tty8.service
 # systemctl start getty@tty8.service

and then Ctrl-Alt-F8.

Hope this helps.

I googled and found only one possibility: something stays in the foreground at startup. But I do not find anything.

Thanks for your suggestions,

Reply to: