[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: network trouble on stretch

From: ghe2001@gmail.com
To: debianUsers <debian-user@lists.debian.org>

Working on a Dell 5414 laptop, Stretch.

The WiFi works, but the Ethernet doesn"t, and I can"t figure out why.

ip addr:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp0s31f6: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN
group default qlen 1000
link/ether 10:05:01:40:f4:43 brd ff:ff:ff:ff:ff:ff
3: wwp0s20f0u2i12: <BROADCAST,MULTICAST,NOARP> mtu 1500 qdisc noop
state DOWN group default qlen 1000
link/ether 4e:8a:3a:22:b3:df brd ff:ff:ff:ff:ff:ff
4: wlp1s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group
default qlen 1000
link/ether f4:8c:50:17:bc:0e brd ff:ff:ff:ff:ff:ff
5: enx10050149649d: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state
DOWN group default qlen 1000
link/ether 10:05:01:49:64:9d brd ff:ff:ff:ff:ff:ff


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto wwp0s20f0u2i12
iface wwp0s20f0u2i12 inet static

First I tried with wicd, a network manager (the static def wasn"t in interfaces)

It said the wired interface was up, and assigned the requested IP. It
wasn"t checking after assignment to see if it worked. I turned that
on, and it never came back.

I removed the network monitor and added the static paragraph to the
interface file. ifup and ifdown worked, and ip addr said
wwp0s20f0u2i12 was up.

There are two Ethernet ports on this thing, and I tried both with no
success. I swapped out the Ethernet cable with the same result.

I replaced Stretch with Buster. It works. dhcp (Comcast) or static (my
T1). Using the interfaces file.

BTW. ifconfig fans, wait till you get to Buster -- no ifup or down.
Buster seems to boot using a commented out dhcp paragraph, though.
Running by hand, "/etc/init.d/network reload" loads the correct

The "man interfaces" on Stretch talks a lot about the ethn interfaces.
It does on Buster, too.

This is less than optimal.

What"s going on here? This is Linux, not Winders; Debian, not Ubuntu;
stable, not Sid. This is what we"re supposed to put on Internet
servers? They had time to make something as simple as this work while
it was testing. And to correct the man pages, too.

If they didn"t have time, the release should have been postponed until
it was ready for prime time, IMHO.

I looked on the "Net, asking why the interface names were changed. I
found a good reason: sometimes the ethn names aren"t reliably
consistent. Fine, I say, you"ve figured how to make them consistent.
That"s no reason to change the names from a meaningful 4 or 5 chars to
11, chosen by /dev/urandom.

Somebody"s selling the Debian management a pile of bull excrement.

Before you get a long lecture on the merits of long unique names try this:

Edit your /etc/default/grub change GRUB_CMDLINE_LINUX=”” to :
GRUB_CMDLINE_LINUX="net.ifnames=0" If the biosdevname is installed you need to add :
GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"
$ sudo update-grub
$ sudo reboot

Now check your /dev/interfaces, they should be eth0 and wlan0 and they will stay
this way.

Glenn English

Reply to: