[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Darn 'beep' stoped working after installing Stretch in place of Jessie

On 08/02/2017 10:38 AM, davidson@freevolt.org wrote:
On Mon, 31 Jul 2017, Juan R. de Silva wrote:

Hi folks,

I installed (fresh install instead of an upgrade) Debian Stretch on my laptop. The installation is full success without any problem except a little one - 'beep' does not produce a sound neither from CLI nor from a bash scripts. I had
Jessie installed on the same laptop before and it worked just fine.

I checked everything I possibly could: pcspkr module loaded, alsa does not have any muted channels, tried to use it as a user and as a root. No clue why it does
not work any longer in Strech.

Any suggestions?

Possibly the following excerpt from https://github.com/johnath/beep/
applies. (TLDR: Skip to the end, read the last three quoted lines.)

| A note about ioctl
| ------------------

| What this means is that root can always make beep work (to the best
| of my knowledge!), and that any local user can make beep work, BUT a
| non-root remote user cannot use beep in it's natural state.

Amazingly, I tried 'sudo beep' in Konsole and it worked! So this is not going to be a problem for my script because some items in the script use sudo anyway. I'll just do that with beep as well.

Reply to: