[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

dpkg error



I'm trying to upgrade my packages, but am getting:

root@picam1:~# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  uv4l-raspidisp-extras
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 422 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 104725 files and directories currently installed.)
Removing uv4l-raspidisp-extras (1.5) ...
insserv: warning: script 'uv4l_uvc' missing LSB tags and overrides
insserv: There is a loop between service watchdog and uv4l_uvc if stopped
insserv:  loop involving service uv4l_uvc at depth 2
insserv:  loop involving service watchdog at depth 1
insserv: Stopping uv4l_uvc depends on watchdog and therefore on system
facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package uv4l-raspidisp-extras (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 uv4l-raspidisp-extras
E: Sub-process /usr/bin/dpkg returned an error code (1)


How do I get out of this pickle?


Reply to: