[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Kingston Thumb Drive Comatose.

	I have a 128 GB thumb drive which has been sitting in a
drawer for 2 or 3 years because it is not completely dead but had
a traumatic event.

	It worked fine until the night it accidentally got
over-filled after a backup script tried to put this drive's own
file system back in to it in an infinite recursive loop which is
what you get when one forgets to exclude the mount point.

	Of course, what should have happened was a "Write failed"
condition but what actually happened seems to be that the
controller in the Kingston drive lost track of where to put
anything so it now can't even find the SDRAM that makes up the

	The drive makes the /dev/sdX node as one might expect but
any attempt to read or write the node such as to reformat it or
use fdisk on it fails with a "no medium found" message.

	Since this was a backup drive, I simply got another drive
and backed up to it so I just want to be able to use this drive
again since the failure is probably not due to actual
hardwarefailure but could be called a design flaw since the drive
should protect itself from this sort of issue.

	Has the state of the art improved any recently so that
Linux users have any tools that can unstick the Kingston's
controller? The data are probably not of any importance any
longer but the drive probably cost close to $100 when it was new
and it seems so close to being usable. Any constructive ideas are
Here is what syslog shows when the drive is inserted:

audio2 kernel: [82157.422619] usb 1-1: new full-speed USB device number 2 using uhci_hcd
kernel: [82157.734651] usb 1-1: new full-speed USB device number 3 using uhci_hcd
kernel: [82157.909640] usb 1-1: New USB device found, idVendor=13fe, idProduct=3100
kernel: [82157.913558] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
kernel: [82157.917858] usb 1-1: Product: 2233 PRAM               
kernel: [82157.920367] usb 1-1: Manufacturer:                         
kernel: [82157.987815] usb-storage 1-1:1.0: USB Mass Storage device detected
kernel: [82157.999983] scsi2 : usb-storage 1-1:1.0
kernel: [82158.010244] usbcore: registered new interface driver usb-storage
kernel: [82159.011680] scsi 2:0:0:0: Direct-Access              2233 PRAM        1.00 PQ: 0 ANSI: 0 CCS
kernel: [82159.037067] sd 2:0:0:0: Attached scsi generic sg3 type 0
kernel: [82159.063686] sd 2:0:0:0: [sdc] Attached SCSI removable disk

Reply to: