[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: chromium error: Error initializing NSS without a persistent database: NSS error code: -8023


] I'm using Wheezy and chromium. Chromium has been working well until
] today. When I ran chromium from the shell, I saw this message:
]     [31:31:1029/204029:ERROR:nss_util.cc(211)] Error initializing NSS \
]     without a persistent database: NSS error code: -8023
] and chromium can't open any page.

Executive summary:

    |    In /etc/chromium/default, set                                |
    |    EXTRALIB=/usr/lib/xulrunner-24.0:/usr/lib/xulrunner-1.9.1    |

Long explanation:

I believe I've solved the problem. Chromium can't seem to find

>From three things: (1) my doing an "apt-file search libnss3", (2) the
notes on this web page:

    [Solved] How to install Old Chromium?

, and (3) my finding no libnss3.so under /usr/lib/chromium, I sus-
pected that chromium's LD_LIBRARY_PATH was broken. I made this change
to /etc/chromium/default, and it seems to solve the problem. My chromium
browser now successfully launches.

    /etc/chromium% diff -u default.orig default
    --- default.orig        2013-08-02 08:06:13.000000000 -0700
    +++ default     2016-11-06 04:17:36.000000000 -0800
    @@ -3,3 +3,6 @@
     # Options to pass to chromium
    +# end


Interestingly, my system, being of this version:

    % chromium --version
    Chromium 37.0.2062.120 Built on Debian 7.6, running on Debian 7.11
    % uname -a
    Linux myhost 3.2.0-4-amd64 #1 SMP Debian 3.2.82-1 x86_64 GNU/Linux
    % lsb_release -a
    No LSB modules are available.
    Distributor ID: Debian
    Description:    Debian GNU/Linux 7.11 (wheezy)
    Release:        7.11
    Codename:       wheezy

has four libnss3.so's:

    1 root root  982512 Oct 16 07:09 /usr/lib/icedove/libnss3.so
    1 root root  974064 Apr 26  2016 /usr/lib/iceweasel/libnss3.so
    1 root root 1316728 Oct 20 13:32 /usr/lib/x86_64-linux-gnu/libnss3.so
    1 root root  973984 Oct 25  2014 /usr/lib/xulrunner-24.0/libnss3.so

Setting EXTRALIB in /etc/chromium/default to each of these four
values in turn yields these results:

    SUCCESS     EXTRALIB=/usr/lib/icedove:/usr/lib/xulrunner-1.9.1
    SUCCESS     EXTRALIB=/usr/lib/iceweasel:/usr/lib/xulrunner-1.9.1
    FAIL        EXTRALIB=/usr/lib/x86_64-linux-gnu:/usr/lib/xulrunner-1.9.1
    SUCCESS     EXTRALIB=/usr/lib/xulrunner-24.0:/usr/lib/xulrunner-1.9.1

(Where does that /usr/lib/xulrunner-1.9.1 come from? It wasn't
originally in the file /etc/chromium/default. But it *is* in
/usr/bin/chromium like so:
[Even though my system has no /usr/lib/xulrunner-1.9.1 directory!]
So I superstitiously included it along with the good directory in
/etc/chromium/default. However, it's not necessary; the four tests
above turned out exactly the same with no mention of it, i.e. with
only the first directory e.g. /usr/lib/xulrunner-24.0 specified.)

                                                          fortune cookie
             |    "While you recently had your problems on the run,    |
             |    they've regrouped and are making another attack."    |

Eric De Mund                               |  Yahoo: ead0002
ead@ixian.com                              |  GTalk: ead.ixian@gmail.com

Reply to: