[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bootable USB won't working

On Sat, 02 Apr 2016 21:29:23 +0530
Akhil Krishnan S <akhilkrishnans@gmail.com> wrote:

> Hi list,
> Recently I tried to reinstall Debian in my Dell Inspiron system by making bootable USB. (Used both dd command and unetbootin)

Please reproduce the exact command you used. It should be something along the lines of:

# dd if=debian.iso of=/dev/sdb bs=4M

followed by a sync.

> But my system doesn't considering it and booting direct to hard disk. (Of course, boot priority of USB is greater than HDD)

Is there a "boot override" option in your BIOS settings? Could you use that to override the boot order and directly specify a USB boot?

> Result is same when tried with Arch also. But when I tried with some older versions of both, works perfectly. What's wrong with my system.

What is "older" about these previous media? The images you used to create them? The media itself (USB, CD)?

> Thanks in advance.

Try and re-download the image (I assume you are using an amd64 system):

$ wget http://cdimage.debian.org/debian-cd/current/amd64/iso-cd/debian-8.3.0-amd64-netinst.iso

If your connection cuts out and the download stops mid-way, run this:

$ wget -c http://cdimage.debian.org/debian-cd/current/amd64/iso-cd/debian-8.3.0-amd64-netinst.iso

Then insert your USB media, and unmount it:

$ umount /dev/sdb*

changing /dev/sdb* to whatever drive letter it actually gets assigned to (i.e. /dev/sdc*).

Now write the image to the drive:

# dd if=debian-8.3.0-amd64-netinst.iso of=/dev/sdb bs=4M
$ sync

Now remove the drive and try boot with it ("boot override" if possible). If you follow these steps to the letter, and the problem persists, then it is a hardware fault.

Attachment: pgp9jaAb62kJ_.pgp
Description: OpenPGP digital signature

Reply to: