[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No irq handler for vector

On 2016-03-16 at 01:00, kamaraju kusumanchi wrote:

>> From time to time, this message is printed on my konsole.
> Message from syslogd@hogwarts at Mar 16 00:12:49 ...
>  kernel:[1219588.659735] do_IRQ: 1.170 No irq handler for vector (irq -1)
> What does it mean? How I can rectify the problem? Is something wrong
> with my hardware or is any component on my computer going bad?

I had this for months on end, but it stopped happening a month or two
ago. You can find mention of it by Googling on 'do_IRQ no IRQ handler
for vector 1' without quotes. (Note that that's '1' rather than '-1', to
accommodate Google's search syntax. Yes, this finds the right results.)

In my case, it meant that a microcode update which was/is needed on my
combination of CPU and motherboard was not being applied. This appeared
to be because Intel decided that on-the-fly microcode updates in the way
that everyone had been doing them for years were not safe, and no longer
supported, on at least some CPU models - and so dropped those updates
from their shipped microcode files. When the Debian package with those
files and/or the tool which applies them was updated to the version
which included that change, this message started appearing.

The official "right" solution is apparently to update the BIOS/UEFI on
your motherboard to one which deals with the issue at that level.

In my case, there was no such BIOS/UEFI version available, and my
motherboard is old enough that none was or is likely to be coming up. I
tried various things, none of which worked, and eventually just gritted
my teeth and bore with it. It doesn't seem to cause or reflect any
actual functional problem, just a really severe cosmetic issue (which
can cause some functional difficulties in practice, because this appears
in every terminal - virtual or otherwise - on the entire system).

Then, a couple of months back, it stopped happening. I do not know what
caused the change, but in current Debian testing, it does not happen for
me anymore.

   The Wanderer

The reasonable man adapts himself to the world; the unreasonable one
persists in trying to adapt the world to himself. Therefore all
progress depends on the unreasonable man.         -- George Bernard Shaw

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: