[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian sid transition to KDE 5?



Hello,

2015-09-15 20:48 GMT+02:00  <amont@tiscali.it>:
> If I give apt-get update, I get
>
> root@debian:/home/andrea# apt-get upgrade
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Calculating upgrade... Done
> The following packages have been kept back:
>   akonadi-backend-mysql akonadi-server akregator apper appstream-index apt
> apt-utils aptitude aptitude-common ark asymptote bluedevil build-essential
> cdrdao chromium
>   coinor-libcgl1 coinor-libclp1 cpp cups-filters cups-filters-core-drivers
> darktable darktable-dbg dolphin dragonplayer ffmpeg2theora ffmpegthumbs
> filezilla filezilla-common
>   firebird2.5-server-common g++ gcc gcc-5-base gcc-5-base:i386 gdb gdisk
> gfortran ghostscript glib-networking glib-networking-services gnupg-agent
> gnupg2 gnuplot
>   gstreamer0.10-plugins-good gstreamer1.0-libav gstreamer1.0-plugins-bad
> gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gwenview handbrake hugin
> hugin-data hugin-tools
>   icedtea-7-jre-jamvm iceweasel icu-devtools juk k3b kaddressbook kate
> kate-data katepart kde-baseapps kde-plasma-desktop kde-runtime kde-standard
> kde-style-oxygen
>   kde-window-manager kde-workspace kde-workspace-bin kde-workspace-data
> kde-workspace-kgreet-plugins kdelibs-bin kdelibs5-data kdelibs5-plugins
> kdepim-kresources kdepim-runtime
>   kdepimlibs-kio-plugins kdeplasma-addons-data kdm kdoctools kinfocenter
> kmail knotes konsole kontact kopete korganizer kscreen kwrite libaacs0
> libakonadi-calendar4
>   libakonadi-contact4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4
> libakonadi-notes4 libakonadiprotocolinternals1 libappstream2
> libasound2-plugins libasound2-plugins:i386
>   libasprintf-dev libatomic1 libavcodec-dev libavformat-dev
> libavresample-dev libavutil-dev libbaloofiles4 libbaloopim4 libbalooxapian4
> libboost-filesystem-dev
>   libboost-iostreams-dev libboost-system-dev libcalendarsupport4
> libcdr-0.1-1 libchromaprint0 libcilkrts5 libcuda1 libcuda1:i386 libcurl3
> libcurl3-gnutls libcurl4-gnutls-dev
>   libdap-dev libdrm-dev libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2
> libdrm-nouveau2:i386 libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386
> libegl1-nvidia
>   libeventviews4 libfbembed2.5 libfollowupreminder4 libgcc1 libgcc1:i386
> libgdal-dev libgegl-0.2-0 libgeos-dev libgfortran3 libgl1-mesa-dri
> libgl1-mesa-dri:i386
>   libgl1-nvidia-glx libgl1-nvidia-glx:i386 libgles1-nvidia libgles2-nvidia
> libgomp1 libgs9 libgs9-common libgstreamer-plugins-bad1.0-0 libharfbuzz-icu0
> libhdf5-8 libhdf5-cpp-8
>   libhdf5-dev libhunspell-1.3-0 libicu-dev libicu52 libincidenceeditorsng4
> libitm1 libjack-jackd2-0 libjack-jackd2-0:i386 libjsoncpp-dev libk3b6
> libk3b6-extracodecs libkabc4
>   libkalarmcal2 libkateinterfaces4 libkatepartinterfaces4 libkblog4 libkcal4
> libkcalcore4 libkcalutils4 libkcddb4 libkcmutils4 libkde3support4
> libkdeclarative5
>   libkdecorations4abi2 libkdecore5 libkdepim4 libkdepimdbusinterfaces4
> libkdesu5 libkdeui5 libkdewebkit5 libkdgantt2-0 libkdnssd4 libkemoticons4
> libkephal4abi1 libkexiv2-11
>   libkf5bluezqt-data libkf5globalaccel-bin libkf5globalaccel-data
> libkf5globalaccel5 libkf5khtml-data libkf5khtml5 libkf5threadweaver5
> libkf5wallet-bin libkf5wallet-data
>   libkf5wallet5 libkfile4 libkfilemetadata4 libkholidays4 libkhtml5
> libkidletime4 libkimap4 libkio5 libkjsapi4 libkjsembed4 libkldap4 libkleo4
> libkmanagesieve4 libkmbox4
>   libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4
> libknotifyconfig4 libkntlm4 libkopete4 libkparts4 libkpathsea6 libkpgp4
> libkpimidentities4 libkpimtextedit4
>   libkpimutils4 libkprintutils4 libkpty4 libkresources4 libkrosscore4
> libkrossui4 libkscreensaver5 libksgrd4 libksieve4 libksieveui4
> libktexteditor4 libktnef4
>   libkunitconversion4 libkutils4 libkwalletbackend5-5 libkwineffects1abi5
> libkwinglesutils1 libkwinglutils1abi2 libkworkspace4abi2 libkxmlrpcclient4
> libllvm3.4 libllvm3.4:i386
>   liblsan0 libmagickcore-6.q16-2-extra libmailcommon4 libmailimporter4
> libmailtransport4 libmediastreamer-base3 libmessagecomposer4 libmessagecore4
> libmessagelist4
>   libmessageviewer4 libmicroblog4 libmspub-0.1-1 libmwaw-0.3-3 libnepomuk4
> libnepomukquery4a libnepomukutils4 libnetcdf-dev libnoteshared4 libnotmuch4
> libnvidia-eglcore
>   libnvidia-ml1 libofa0 libopenconnect5 libopencv-calib3d2.4
> libopencv-contrib2.4 libopencv-core2.4 libopencv-features2d2.4
> libopencv-flann2.4 libopencv-highgui2.4
>   libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4
> libopencv-objdetect2.4 libopencv-video2.4 libpackagekit-glib2-18
> libpam-systemd libpcre16-3 libpcre3 libpcre3:i386
>   libpcre3-dev libpcre32-3 libpimcommon4 libplasma-geolocation-interface4
> libplasma3 libplasmaclock4abi4 libplasmagenericshell4 libpod-readme-perl
> libprocesscore4abi1
>   libprocessui4a libproxy-tools libpsl0 libpstoedit0c2a libptexenc1 libqca2
> libqca2-plugins libqgpgme1 libqt4-dbus libqt4-dbus:i386 libqt4-declarative
>   libqt4-declarative-gestures libqt4-declarative-particles libqt4-designer
> libqt4-dev libqt4-dev-bin libqt4-help libqt4-network libqt4-network:i386
> libqt4-opengl
>   libqt4-opengl:i386 libqt4-opengl-dev libqt4-qt3support libqt4-script
> libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg
> libqt4-test libqt4-xml
>   libqt4-xml:i386 libqt4-xmlpatterns libqt4-xmlpatterns:i386 libqt5clucene5
> libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5designer5
> libqt5designercomponents5 libqt5gui5
>   libqt5help5 libqt5network5 libqt5opengl5 libqt5opengl5-dev
> libqt5printsupport5 libqt5sql5 libqt5test5 libqt5webkit5 libqt5webkit5-dev
> libqt5widgets5 libqt5xml5 libqtcore4
>   libqtcore4:i386 libqtcore4-perl libqtdbus4 libqtdbus4:i386 libqtglib-2.0-0
> libqtgui4 libqtgui4:i386 libqtgui4-perl libqtruby4shared2 libqtwebkit-dev
> libqtwebkit4
>   libqtwebkit4:i386 libquadmath0 libreoffice libreoffice-base
> libreoffice-base-core libreoffice-base-drivers libreoffice-calc
> libreoffice-common libreoffice-core
>   libreoffice-draw libreoffice-help-en-gb libreoffice-help-en-us
> libreoffice-impress libreoffice-kde libreoffice-l10n-en-gb libreoffice-math
> libreoffice-style-galaxy
>   libreoffice-style-oxygen libreoffice-writer libsendlater4
> libsmokekdecore4-3 libsmokekdeui4-3 libsmokekfile3 libsmokekhtml3
> libsmokekio3 libsmokeknewstuff2-3
>   libsmokeknewstuff3-3 libsmokekparts3 libsmokektexteditor3 libsmokekutils3
> libsmokeplasma3 libsmokeqtcore4-3 libsmokeqtdbus4-3 libsmokeqtgui4-3
> libsmokeqtnetwork4-3
>   libsmokeqtopengl4-3 libsmokeqtsql4-3 libsmokeqtsvg4-3 libsmokeqtxml4-3
> libsmokesolid3 libsolid4 libsoprano4 libspatialite-dev libstdc++6
> libstdc++6:i386 libswscale-dev
>   libsynctex1 libsyndication4 libsystemd0 libtaskmanager4abi4 libtbb2
> libtemplateparser4 libtexlua52 libtexluajit2 libtext-bibtex-perl
> libthreadweaver4 libtsan0 libubsan0
>   libudev1 libunicode-linebreak-perl libvigraimpex4 libvlc5 libvlccore8
> libvtk5.8 libvtk6-dev libweather-ion6 libxatracker2 libxerces-c-dev
> libxerces-c3.1 libxml2 libxml2-dev
>   libzrtpcpp2 linux-headers-amd64 linux-image-amd64 lsb-release minidlna
> notmuch nvidia-alternative nvidia-driver nvidia-driver-bin
> nvidia-kernel-dkms nvidia-smi
>   nvidia-vdpau-driver octave octave-common octave-control
> octave-econometrics octave-general octave-gsl octave-io
> octave-linear-algebra octave-optim octave-parallel
>   octave-signal octave-statistics octave-struct octave-tsa okular
> okular-extra-backends openjdk-7-jdk openjdk-7-jre openjdk-7-jre-headless
> packagekit packagekit-tools
>   pavucontrol phonon-backend-gstreamer phonon-backend-gstreamer-common
> plasma-dataengines-addons plasma-dataengines-workspace plasma-desktop
> plasma-runners-addons
>   plasma-scriptengine-javascript plasma-wallpapers-addons
> plasma-widgets-addons poppler-utils powertop printer-driver-brlaser
> python-apt python-cryptography python-vtk6
>   python-xapian python3-apt python3-uno qapt-batch qdbus
> qml-module-org-kde-bluezqt qpdf qt4-designer qt4-dev-tools
> qt4-linguist-tools qt4-qmake qt4-qmlviewer qt5-qmake
>   qtbase5-dbg qtbase5-dev qtbase5-dev-tools qttools5-dev r-cran-gam
> r-cran-lme4 r-cran-rcpp rawtherapee ruby-qt4 scidavis sflphone-daemon
> sflphone-data sflphone-kde
>   soprano-daemon synaptic systemd task-british-desktop
> task-british-kde-desktop task-desktop task-english task-kde-desktop
> task-laptop tasksel tasksel-data tcl-vtk6
>   texlive-binaries udev ufraw ufraw-batch uno-libs3 ure vlc vlc-data vlc-nox
> vlc-plugin-notify vlc-plugin-samba vtk6 xserver-xorg-video-nvidia
> 0 upgraded, 0 newly installed, 0 to remove and 529 not upgraded.

What apt-mark showhold says ? Maybe there is some packages on hold status?
What apt-cache policy apt says ? (apt is only one of the packages
which doesn't want to upgrade on your system)
What apt (or apt-get) install apt says (after apt update)? (try to
upgrade only apt, to see what happen)

I'm not sure why there are these 529 packags in a non upgradable
status. I have 164 packages installed that are on your list, and all
upgraded to the latest unstable version (105 of them has lib on their
names) on this system

Regards,


Reply to: