[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

aptitude full-upgrade causes lots of errors (debian/testing)

Dear mainainers,

it looks like aptituide full-upgrade cannot be done at the moment (and 
upgrading fro stable to testing, too).

The reason is for a lot of dependency problems as you see below.

Is there anything the user can do or must it be fixed by the repository 

Here is the output:

he following packages are RECOMMENDED but will NOT be installed:
  ktnef libcanberra-gstreamer libcanberra-pulse libreoffice-style-breeze sound-
theme-freedesktop user-manager 
421 packages upgraded, 91 newly installed, 0 to remove and 0 not upgraded.
Need to get 532 MB of archives. After unpacking 539 MB will be used.
The following packages have unmet dependencies:
 libmatroska6v5 : Breaks: libmatroska6 but 1.4.2-2 is installed.
 libbinio1v5 : Conflicts: libbinio1ldbl but 1.4+dfsg1-4 is installed.
 libid3-3.8.3v5 : Conflicts: libid3-3.8.3c2a but 3.8.3-16 is installed.
 libgsmme1v5 : Conflicts: libgsmme1c2a but 1.10+20120414.gita5e5ae9a-0.2 is 
 libdapserver7v5 : Breaks: libdapserver7 but 3.14.0-2 is installed.
 libtag1v5-vanilla : Breaks: libtag1-vanilla but 1.9.1-2.1 is installed.
 libmagick++-6.q16-5v5 : Conflicts: libmagick++-6.q16-5 but 8: is 
 libopencv-ml2.4 : Depends: libopencv-core2.4 (= but is to be installed.
 libpangomm-1.4-1v5 : Conflicts: libpangomm-1.4-1 but 2.36.0-1 is installed.
 libdap17v5 : Breaks: libdap17 but 3.14.0-2 is installed.
 libatkmm-1.6-1v5 : Breaks: libatkmm-1.6-1 but 2.22.7-2.1 is installed.
 libopencv-video2.4 : Depends: libopencv-imgproc2.4 (= 
but is to be installed.
 liborcus-0.10-0v5 : Conflicts: liborcus-0.10-0 but 0.9.2-1 is installed.
 libqpdf13v5 : Breaks: libqpdf13 but 5.1.3-1 is installed.
 libtag1v5 : Conflicts: libtag1c2a but 1.9.1-2.1 is installed.
 libasprintf0v5 : Breaks: libasprintf0c2 but 0.19.4-1 is installed.
 libucommon7v5 : Conflicts: libucommon7 but 6.3.4-1 is installed.
 libopenexr6v5 : Conflicts: libopenexr6 but 1.6.1-8 is installed.
 libgpgme++2v5 : Breaks: libgpgme++2 but 4:4.14.2-2+b1 is installed.
 libcgal11v5 : Conflicts: libcgal11 but 4.6.1-1 is installed.
 libebml4v5 : Breaks: libebml4 but 1.3.1-3 is installed.
 libgconfmm-2.6-1v5 : Conflicts: libgconfmm-2.6-1c2 but 2.28.0-1.1 is 
 libopencv-legacy2.4 : Depends: libopencv-highgui2.4 (= 
but is to be installed.
 libopencv-imgproc2.4v5 : Conflicts: libopencv-imgproc2.4 but is to be installed.
 libpcrecpp0v5 : Conflicts: libpcrecpp0 but 2:8.35-7 is installed.
 libclucene-contribs1v5 : Conflicts: libclucene-contribs1 but is 
 libflac++6v5 : Breaks: libflac++6 but 1.3.1-2 is installed.
 libvamp-hostsdk3v5 : Breaks: libvamp-hostsdk3 but 2.6~repack0-1 is installed.
 libgtkmm-2.4-1v5 : Breaks: libgtkmm-2.4-1c2a but 1:2.24.4-1.1 is installed.
 libqalculate5v5 : Conflicts: libqalculate5 but 0.9.7-9 is installed.
 libcmis-0.5-5v5 : Conflicts: libcmis-0.5-5 but 0.5.0-2 is installed.
 libwxbase3.0-0v5 : Breaks: libwxbase3.0-0 but 3.0.2+dfsg-1 is installed.
 libmusicbrainz3-6v5 : Conflicts: libmusicbrainz3-6 but 3.0.2-2.2 is installed.
 libopencv-features2d2.4 : Depends: libopencv-imgproc2.4 (= but is to be installed.
 libopencv-objdetect2.4 : Depends: libopencv-highgui2.4 (= but is to be installed.
 libilmbase6v5 : Conflicts: libilmbase6 but 1.0.1-6.1 is installed.
 libwxgtk3.0-0v5 : Breaks: libwxgtk3.0-0 but 3.0.2+dfsg-1 is installed.
 libafflib0v5 : Conflicts: libafflib0 but 3.7.6-2 is installed.
 libpodofo0.9.0v5 : Conflicts: libpodofo0.9.0 but 0.9.0-1.2+b2 is installed.
 libclucene-core1v5 : Conflicts: libclucene-core1 but is installed.
 libgdal1i : Breaks: libgdal1h (< 1.11.2+dfsg-1~exp4) but 1.10.1+dfsg-9+b1 is 
 libreoffice-common : Breaks: libreoffice-style-crystal (< 1:5.0~) but 1:4.4.5-2 
is installed.
 libkf5bluezqt5 : Depends: libkf5bluezqt-data (= 5.3.1-1) but 5.13.0-1 is to 
be installed.
 libtsk10v5 : Conflicts: libtsk10 but 4.1.3-8 is installed.
 libopencv-core2.4v5 : Conflicts: libopencv-core2.4 but is 
to be installed.
 libcairomm-1.0-1v5 : Conflicts: libcairomm-1.0-1 but 1.10.0-1.1 is installed.
 libxapian22v5 : Conflicts: libxapian22 but 1.2.21-1 is installed.
 libgeos-c1v5 : Breaks: libgeos-c1 (< 3.4.2-8~) but 3.4.2-7 is installed.
 libgltf-0.0-0v5 : Conflicts: libgltf-0.0-0 but 0.0.2-3 is installed.
 libkolabxml1v5 : Breaks: libkolabxml1 but 1.1.0-3 is installed.
 libsigc++-2.0-0v5 : Conflicts: libsigc++-2.0-0c2a but 2.4.1-1 is installed.
 libdapclient6v5 : Breaks: libdapclient6 but 3.14.0-2 is installed.
 libstreams0v5 : Breaks: libstreams0 but 0.7.8-1.2+b3 is installed.
 libgtkmm-3.0-1v5 : Conflicts: libgtkmm-3.0-1 but 3.16.0-1 is installed.
 libsidplayfp4 : Conflicts: libsidplayfp3 but 1.7.2-1 is installed.
 libkolab0v5 : Breaks: libkolab0 but 0.6.0-1 is installed.
 libproxy1v5 : Conflicts: libproxy1 but 0.4.11-4+b2 is installed.
 libsmokebase3v5 : Conflicts: libsmokebase3 but 4:4.14.2-1 is installed.
 libopencv-contrib2.4 : Depends: libopencv-highgui2.4 (= 
but is to be installed.
 libstreamanalyzer0v5 : Breaks: libstreamanalyzer0 but 0.7.8-1.2+b3 is 
 libstdc++6 : Breaks: digikam-private-libs (<= 4:4.4.0-1.1+b2) but 
4:4.4.0-1.1+b2 is installed.
              Breaks: libboost-date-time1.55.0 but 1.55.0+dfsg-4 is installed.
              Breaks: libdap17 (<= 3.14.0-2) but 3.14.0-2 is installed.
              Breaks: libdapclient6 (<= 3.14.0-2) but 3.14.0-2 is installed.
              Breaks: libdapserver7 (<= 3.14.0-2) but 3.14.0-2 is installed.
              Breaks: libkolabxml1 (<= 1.1.0-3) but 1.1.0-3 is installed.
 libglibmm-2.4-1v5 : Conflicts: libglibmm-2.4-1c2a but 2.44.0-1 is installed.
 libccrtp2v5 : Conflicts: libccrtp2 but 2.0.9-2+b3 is installed.
 libopencv-flann2.4 : Depends: libopencv-core2.4 (= but is to be installed.
 libbt0v5 : Conflicts: libbt0 but 0.70.1-29 is installed.
open: 4994; closed: 6911; defer: 9; conflict: 10                                                                                             
oNo solution found within the allotted time.  Try harder? [Y/n] 

Thanky for reading this mail.

Happy hacking.


Reply to: