[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: New Jessie Install: Laptop fan doesn't run

On 2015-05-03 16:00, Glen Reesor wrote:

On 2015-05-03 14:20, Ralph Katz wrote:
Hash: SHA512

Please don't top post; it makes following the thread harder. My reply
follows below...

On 05/02/2015 07:23 PM, Glen Reesor wrote:
I've done some more research, and it appears that the fan control is
only happening at boot, in *both* the installed system and the livecd.
So if the machine is hot at boot, the fan runs and stays running
regardless of temperature changes. If the machine is cool at boot, the
fan doesn't run, regardless of temperature changes.

I've discovered interesting behavior with the sensors command and acpi -t.

Sensors currently shows:
    Adapter: Virtual device
    temp1:        +40.0°C  (crit = +100.0°C)     <----- This never
changes after boot

    Adapter: ISA adapter
    Core 0:       +56.0°C  (high = +100.0°C, crit = +100.0°C)
    Core 1:       +57.0°C  (high = +100.0°C, crit = +100.0°C)

However acpi -t shows:
    Thermal 0: ok, 40.0 degrees C

The temp1 line reported by sensors never changes after boot, and neither
does the output from acpi -t. So it looks like acpi is looking at the
wrong temperature, as it's only the Core 0 and Core 1 temperatures that

On 2015-05-02 10:02, Glen Reesor wrote:
Some more information...

I have confirmed that the fan runs when the Jessie livecd is running,
but the fan doesn't run for amd64 or i386 installations. I've compared
syslog, daemon.log, and lsmod and found:

syslog: Both livecd and amd64 installation have these lines:
     kernel: [    0.020564] CPU0: Thermal monitoring enabled (TM1)
     kernel: [    0.943898] thermal LNXTHERM:00: registered as
     kernel: [    0.943904] ACPI: Thermal Zone [TZ01] (50 C)

syslog: There is a slight difference in the following line:
    livecd: kernel: [    3.144083] acpi device:3a: registered as
    amd64: kernel: [    8.712124] acpi device:3a: registered as

lsmod has slight differences:
    livecd: thermal                17343  0
               thermal_sys            27122  3 video,thermal,processor

    amd64: thermal                17559  0
                 thermal_sys            27642  3

In daemon.log, the amd64 installation has the following lines (but
they may be the result of installing the sensors package,
which the livecd does not have):
       May  2 08:36:48 amd64 sensors[492]: acpitz-virtual-0
       May  2 08:36:48 amd64 sensors[492]: Adapter: Virtual device
       May  2 08:36:48 amd64 sensors[492]: temp1: +0.0°C  (crit
= +100.0°C)
       May  2 08:36:48 amd64 sensors[492]: coretemp-isa-0000
       May  2 08:36:48 amd64 sensors[492]: Adapter: ISA adapter
       May  2 08:36:48 amd64 sensors[492]: Core 0: +25.0°C  (high
= +100.0°C, crit = +100.0°C)
       May  2 08:36:48 amd64 sensors[492]: Core 1: +26.0°C  (high
= +100.0°C, crit = +100.0°C)

Any help would be greatly appreciated.


On 2015-04-30 20:40, Glen Reesor wrote:
I have done a fresh install of Jessie on an old Acer laptop and the
fan never runs, so it overheats. Interestingly, the fan *does* run
while Jessie is being installed.

Has anyone had similar problems? Does anyone have suggestions on how
to diagnose this?


Glen, I'm not sure how much this will help, but my old Acer laptop
running Jessie seems to be fine out of the box.  Here are some
comparable outputs [pasted as quotes to prevent line wrapping]:

ralph@spike2 ~$ zgrep sensors /var/log/daemon.log*
/var/log/daemon.log.1:Apr 27 15:48:53 spike2 sensors[864]: acpitz-virtual-0 /var/log/daemon.log.1:Apr 27 15:48:53 spike2 sensors[864]: Adapter: Virtual device /var/log/daemon.log.1:Apr 27 15:48:53 spike2 sensors[864]: temp1: +50.0°C (crit = +87.0°C) /var/log/daemon.log.1:Apr 27 15:48:53 spike2 sensors[864]: temp2: +45.0°C (crit = +105.0°C) /var/log/daemon.log.1:Apr 27 15:48:53 spike2 sensors[864]: coretemp-isa-0000 /var/log/daemon.log.1:Apr 27 15:48:53 spike2 sensors[864]: Adapter: ISA adapter /var/log/daemon.log.1:Apr 27 15:48:53 spike2 sensors[864]: Core 0: +44.0°C (high = +85.0°C, crit = +85.0°C) /var/log/daemon.log.1:Apr 27 15:48:53 spike2 sensors[864]: Core 1: +47.0°C (high = +85.0°C, crit = +85.0°C)
ralph@spike2 ~$ acpi -t -i
Thermal 0: ok, 39.0 degrees C
Thermal 0: trip point 0 switches to mode critical at temperature 105.0 degrees C
Thermal 1: ok, 39.0 degrees C
Thermal 1: trip point 0 switches to mode critical at temperature 87.0 degrees C Thermal 1: trip point 1 switches to mode passive at temperature 83.0 degrees C
ralph@spike2 ~$
Have you checked bug reports or searched the archives for hints?   A
quick search will give you some clues:

Also some packages may help, check out fancontrol and thinkfan. There
are others.

Keep us posted.  And please reply below this post so discussion flows

Good luck!


Version: GnuPG v1
Comment: Using GnuPG with Icedove - http://www.enigmail.net/


Hi Ralph,
Thanks for the suggestions.

I've tried the fancontrol package, however it requires a configuration file written by pwmconfig, and pwmconfig reports "There are no pwm-capable sensor modules installed".

This lack of pwm-capable sensors also means that I can't use thinkfan.

I've checked bug reports, and there are none that fit my description. I submitted my own bug report, since the lack of fan means that installation fails when encrypted lvm is used (system shuts down
before it finishes writing random data to the disk).

The output from acpi -t -i is:
> Thermal 0: ok, 40.0 degrees C
> Thermal 0: trip point 0 switches to mode critical at temperature 100.0 degrees C

Just a quick update that I have solved my problem. After much research, I found this thread for Ubuntu, dating back to 2009: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/451337. It described my problem exactly. Obviously it was too old to try applying the kernel patches. Luckily I had an old XP install disk hanging around and was able to upgrade the firmware. Now, even under load, the temperature never breaks 70C.

Thanks to people who responded.


Reply to: