[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Virtualbox install problems on Wheezy with 3.16.0 backports kernel

On Sat, Dec 27, 2014 at 08:29:38PM -0800, Marc Shapiro wrote:

> ... I have the following installed:
> i    linux-headers-3.16.0-0.bpo.4-amd64                  - Header files for
> Linux 3.16.0-0.bpo.4-amd64
> i A linux-headers-3.16.0-0.bpo.4-common               - Common header files
> for Linux 3.16.0-0.bpo.4
> i    linux-image-3.16-0.bpo.2-amd64                         - Linux 3.16 for
> 64-bit PCs
> i linux-kbuild-3.16                                                  -
> Kbuild infrastructure for Linux 3.16
> i A dkms - Dynamic Kernel Module Support Framework
> i virtualbox-dkms                                                   - x86
> virtualization solution - kernel module sources for dkms
> i virtualbox - x86 virtualization solution - base binaries
> i virtualbox-qt - x86 virtualization solution - Qt based user interface
> I still get the above error when I start virtualbox.  If I click past it and
> try to power up the ReactOS vm, I get:
> ----------------
> Kernel driver not installed (rc=-1908)
> The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there
> is a permission problem with /dev/vboxdrv.
> Please reinstall the kernel module by executing:
> '/etc/init.d/vboxdrv setup'
> as root.  If it is available in your distribution, you should install the
> DKMS package first.  This package keeps track if Linux kernel changes and
> recompiles the vboxdrv kernel module if necessary.
> -----------------
> The problem is that '/etc/init.d/vboxdrv' does not exist.  Neither does
> '/dev/vboxdrv'.  Am I somehow missing a package that should have been
> installed?  Have I missed a step somewhere in installing virtualbox?  How do
> I get vboxdrv installed?

What version of virtualbox does the above represent? 

In my experience dkms for VirtualBox has never worked in Wheezy. I have to
manually compile the module every time I upgrade the kernel.

According to the Debian Wiki, you have to install VirtualBox from backports
if you use a backports kernel:

Hmmm ... that's the x86 version of dkms for an AMD64 kernel. As this list
taught me some time ago, that can cause problems.
Carl Fink                           nitpicking@nitpicking.com 

Read my blog at blog.nitpicking.com.  Reviews!  Observations!
Stupid mistakes you can correct!

Reply to: