[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

how to install amd64 instead i386

Hi everybody,

I install  solydx (debian based ) Amd64.
I have a local mirror ( for amd64)  it works fine on one machine (pure debian)

On solydx64,
when I tried apt-get update, it worked correctly fine  from  remote repositoryserver,  but it  searched  for i386 in from local repository .  
  here is  my source file  and errors

cat /etc/apt/sources.list
deb http://home.solydxk.com/production solydxk main upstream import
 deb http://debian.solydxk.com/production testing main contrib non-free
 deb http://debian.solydxk.com/security testing/updates main contrib non-free
deb http://community.solydxk.com/production solydxk main
deb file:/disk/ftp.fr.debian.org/debian jessie main contrib non-free


# apt-get update
Réception de : 1 file: jessie InRelease [191 kB]
Err file: jessie/main i386 Packages
  Fichier non trouvé       --------------->    means  File not found
Err file: jessie/contrib i386 Packages
  Fichier non trouvé
Err file: jessie/non-free i386 Packages
  Fichier non trouvé
W: Impossible de récupérer file:/disk/ftp.fr.debian.org/debian/dists/jessie/main/binary-i386/Packages
 Fichier non trouvé  -------->   means      file not found 

YES SURE not found   since I HAVE :

# ls /disk/ftp.fr.debian.org/debian/dists/jessie/main/binary-amd64/
Packages  Packages.gz  Packages.xz  Release

Why     it searched for binary-i386/Packages

Thanks for help
best regards

Reply to: